On my white MacBook 2.1 I have to press to my finger really hard to the touchpad to even move the mouse pointer. I did not have to do that when I had OSX installed on it.

Any ideas?


A lot of people with Macbook varieties have installed alternate drivers for the trackpad so they can modify them to their hearts' content. In my case, I installed xf86-input-mtrack driver. To install it, at the terminal type:

sudo apt-get install xserver-xorg-input-mtrack  

Put in password as usual when prompted.

Now you need to actually switch from the old driver (called "multitouch") to this one. You will need to put some entries in /etc/X11/xorg.conf

sudo nano /etc/X11/xorg.conf 

Put in:

    Section "InputClass"
        MatchIsTouchpad          "on"
        Identifier               "Touchpads"
        Driver                   "mtrack"

This is the bare minimum you need in the conf file. You will undoubtedly want to now experiment and tweak it until the driver gets to the Goldilocks "just right" stage.

Here is the readme by the author of the driver: https://github.com/BlueDragonX/xf86-input-mtrack/blob/master/README.md

It explains the different options. Here's an example, using my conf:

     Section "InputClass"
          MatchIsTouchpad    "on"
          Identifier         "Touchpads"
          Driver             "mtrack"
          Option             "Sensitivity"           ".67"
          Option             "TapButton1"            "0"
          Option             "TapButton2"            "0"
          Option             "TapButton3"            "0"
          Option             "ScrollDistance"        "100"
          Option             "FingerHigh"            "8"
          Option             "FingerLow"             "8"

I don't like any of the tapping business, so I turned them off. FingerHigh is what you are most interested in. Default value is 5. It defines the minimum pressure the touchpad will recognize as a touch. As you can see, I found it very sensitive, so I set it to 8.

Now reboot. If all goes well, you've fixed your problem. It's that easy (or at least, it should be -- knock on wood).

Finally, a discussion thread started by the driver author is here: http://ubuntuforums.org/showthread.php?t=1730361

A fair amount of the info in there is outdated, not applicable, or in some cases wrong (some examples of the xorg.conf files mistakenly have "multitouch" where "mtrack" should be). But the initial post is worth reading as it explains the author created dispad to work with the driver, for those who accidentally touch trackpad a lot while typing. I don't have that problem, so I didn't install dispad, but maybe you will need it.

| improve this answer | |
  • 1
    I tried installing it from Terminal, but I got this E: Unable to locate package xserver-xorg-input-mtrack And I can't find it in Synaptic Package Manager. Still, it seems I can edit /etc/X11/xorg.conf... I can try to just edit it, but I don't think it's going to work until the driver is installed, right? – aderojas Feb 15 '12 at 23:31
  • Yes definitely do not edit it until you have the driver! That's strange you can't locate the package. Try sudo apt-get update (to refresh your package listings) and see if it works after that. – Chan-Ho Suh Feb 16 '12 at 0:21
  • Nope, same message :S But I have had trouble installing things from Terminal, that's why I have been using the Synaptic Package Manager. – aderojas Feb 16 '12 at 0:24
  • Maybe I'm missing something in /etc/apt/sources.list, and that's why I get that error on Terminal but it works in SPM? I can also try to install it through git clone git://github.com/BlueDragonX/xf86-input-mtrack.git, although I first have to install git... – aderojas Feb 16 '12 at 0:35
  • I'd say ask as a new question, why apt-get is not finding these packages. It's a more general issue you should get fixed. – Chan-Ho Suh Feb 16 '12 at 0:51

I know this is an old post, but is still a current problem!

I tried this method and all of a sudden my synclient was gone! What have I done!?

| improve this answer | |
  • Welcome to Ask Ubuntu. You could ask new question if you couldn't find a working answer then reference to this one. See askubuntu.com/tour – user.dz Mar 26 '14 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.