1

I used to have Windows and Ubuntu installed on my laptop but I've decided to wipe Windows and just go with Ubuntu. After installing Ubuntu with USB and wiping Windows I've gotten this booting issue.

I've tried reinstalling Ubuntu, having dual installed Ubuntu, and just desperate stuff in general. The error that I get before trying to boot off of my USB is:

Failed to open \EFI\BOOT\mmx64.efi - Not Found
Failed to load image \EFI\Boot\mmx64.efi: Not Found
Failed to start MokManager: Not Found

Current Disk situation from USB non-installed Ubuntu's disk utility:

partition 1

  • Size: 537 MB
  • Device: /dev/sda1
  • Partition Type: EFI System
  • Contents: FAT(32-bit version) - Not Mounted

partition 2

  • Size: 503 GB
  • Device: /dev/sda2
  • Partition Type: Linux Filesystem
  • Contents: Ext (version 1.0) - Not Mounted

partition 3

  • Size: 8.5 GB
  • Device: /dev/sda3
  • Partition Type: Linux Swap
  • Contents: Swap (version 1) - Active

I still have 489GB of free space from the dual boot partition. I'd want to get rid of the partition and just have 1TB Ubuntu but it doesn't even boot.

I've tried boot-repair but still same result.


This post on itsfoss helped me to solve this problem the most.

2
  • Could you please run Boot-Info and edit your question to include a link to its resulting info log? Thanks. – David Foerster Mar 17 '18 at 11:03
  • Don't put solved in the title. To mark an question as solved, click on the check mark beside the best answer to toggle it from greyed out to filled in. – Martin Thornton Mar 17 '18 at 12:45
1

This isn't an MBR issue as you are using a UEFI system.

There should be 2 main boot EFI folders with the following paths: a) /boot/efi/EFI/Boot, and b) /boot/efi/EFI/ubuntu. a) should have these files: bkpbootx64.efi, bootx64.efi and grub64.efi. b) should include: fwupx64.efi, grub.cfg, grub64.efi,mmx64.efi and shimx64.efi. mmx64.efi operates Mokmanager and with shimx64.efi is responsible for booting up via a 'Secure Boot'. The Secure Boot option is available in your BIOS. So it seems likely that mmx64.efi is missing with Secure Boot enabled.

First of all I'd go into BIOS and disable Secure Boot, then save settings and see if GRUB menu appears and you can boot from it. If not, then boot up from live flash drive, mount sda1 and check in terminal to see if all 'efi' files are present as well as in the relevant folders as above. If they are there and you weren't able to boot on your HDD then a re-install is probably necessary, but then mount sda2, find your 'home' folder and back it up if you haven't done so. While you're in live Ubuntu I'd give boot-repair one more try. It's not let me down on the rare occasion I've had boot problems.

2
  • Thank you! This comment help me realize what could have been an issue. I think it was interacting with the USB's BOOT files – Leon Lee Mar 17 '18 at 12:05
  • 1
    @LeonLee, you could accept this answer. Or you could write your own answer with the steps that you preformed to solve the issue. – pa4080 Mar 17 '18 at 12:08
0

This workaround is not exactly an answer but it is too long to for the comments.

Two weeks ago I had similar issue. My installation was relatively new but my user's home directory already was full with my files (and settings). The only difference was that, I haven't received a message like 'Failed to open \EFI\BOOT\mmx64.efi'.

I spent an hour to conclude that the EDI partition is my problem. Then I spent two hours to read suggestions how to recover the EFI partition and Grub after Windows is wiped, but none of them helped my out.

Finally I decided to reinstall Ubuntu without formatting, so I used the same installation media and:

  • On the 'Preparing to install Ubuntu' screen I ticked the options 'Download updates' and "Install third party software'.

    enter image description here

  • On the 'Installation type' screen I choose the option 'Something else'.

    enter image description here

  • On the next screen I pointed out my partitions with their file systems and mount pints, and make sure the format option is not ticked.

    enter image description here

  • Then I've deleted the EFI partition (/dev/sda1 in your case) and created a new one.

    enter image description here

  • On the next steps I used the same user name and password as the previous installation.

  • When the installation process finished and the system booted successfully I did sudo apt update && sudo apt upgrade and also sudo apt install -f but there was nothing to fix. I've reinstalled few packages but all my user's settings was already there.

3
  • This fixed your problem? – pandafy Mar 17 '18 at 6:30
  • @GaganRajput, yes, right that. – pa4080 Mar 17 '18 at 8:18
  • 1
    sorry this didn't really do much for me :( – Leon Lee Mar 17 '18 at 12:04
0

I had this problem and the solution was to rename grubx64.efi tommx64.efi on the USB after writing the .iso to it.

-1

I experienced exactly the above error message but after grub was updated on on my Dual Boot box.

After trying all sorts of solutions I finally realised it was signing issue. The file, /boot/efi/EFI/ubuntu/grubx64.efi had, been updated and was no longer signed.

Into the BIOS settings, (F2 on my ACER), 'Security', 'Add file to EFI Trusted Dbases' (or something similar), navigate to the file I mention above and select it.

All good.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.