2

This applies to a 16.04 Lubuntu system.

There's this related question How to prevent deja-dup-monitor from running, or completely delete it? but that user didn't use deja-dup and just wanted to kill it. Also something about a weird interaction with Google Chrome, also not my issue.

I use deja-dup but only on demand. I don't need its daemon running to kick off automatic backups.

I've killed the daemon and tested backups and restores with it dead and they work fine.

I tried sudo systemctl stop deja-dup-monitor

but I get

Failed to stop deja-dup-monitor.service: Unit deja-dup-monitor.service not loaded.

though it shows up in Task Manager

enter image description here

Also sudo systemctl disable deja-dup-monitor results in

Failed to execute operation: No such file or directory

How can I prevent deja-dup-monitor from starting?

2

According to dpkg -S deja-dup-monitor (or package search) its XDG desktop-autostart file is located in /etc/xdg/autostart/deja-dup-monitor.desktop .

So you can disable deja-dup-monitor autostart by removing this file:

sudo rm /etc/xdg/autostart/deja-dup-monitor.desktop

As @OrganicMarble commented user-oriented solution is to launch lxsession-edit and uncheck Backup Monitor. This will create XDG-user file ~/.config/autostart/deja-dup-monitor.desktop with contents:

[Desktop Entry]
Version=1.0
X-Ubuntu-Gettext-Domain=deja-dup
Name=Backup Monitor
Comment=Schedules backups at regular intervals
Icon=deja-dup
TryExec=/usr/lib/x86_64-linux-gnu/deja-dup/deja-dup-monitor
Exec=/usr/lib/x86_64-linux-gnu/deja-dup/deja-dup-monitor
X-GNOME-Autostart-Delay=120
StartupNotify=false
NoDisplay=true
Type=Application
Categories=Utility;Archiving;
NotShowIn=LXDE;

The main and significant difference between this file and original /etc/xdg/autostart/deja-dup-monitor.desktop is NotShowIn=LXDE; (it means that deja-dup-monitor will not start on LXDE session).

  • 1
    Thanks, I'm gonna accept this because you pointed me to the answer. While your way works perfectly, now that I know it's just autostarted, in Lubuntu, I can just open the LXsession Configuration app, click on Autostart, and untick "Backup Monitor". That way doesn't require sudo or command lines. Thanks again! – Organic Marble Mar 16 '18 at 21:16
  • Updated my answer (clarified your idea). Thank you! – N0rbert Mar 16 '18 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.