0

I have a problem with my WiFi connection, When I am trying to connect to my own WiFi at home everything is fine. if i am connecting to another network and trying to surf (Chrome) I have a note of Resolving host.. and an error of DNS_PROBE_FINISHED_NO_INTERNET and there is no ping to 8.8.8.8 by example.

When I tried route -n I have got: 169.254.0.0 I read a recommend to uninstall avahi-autoipd and now I don't see the zeroconf.

I tried to add name servers to resolv.conf (8.8.8.8 & 8.8.4.4), reconfiguration resolvconf: dpkg-reconfigure resolvconf, uncomment dns=masq etc..

I upgrade my ubuntu from 16.04 to 17.04, But the problem of DNS still as is.

Please try to help me.

Thanks a lot!

2

Step 1: Checking Default route Use one of these commands:

route -n

or

ip r

Ask a new IP address and amend the connection with the next command:

dhclient -v wlan0

Now, all should work fine!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.