0

This question already has an answer here:

A few hours ago, I went in my ACER laptop boot options, for no particular reason. I did not change anything, but noticed that Windows 10 was first in the boot order list while Ubuntu was not there at all. I escaped, and thought Grub would show up... but it did not and Windows booted.

Since then, I've been unable to boot on Ubuntu. Windows automatically boots and Grub does not show up anymore.

In the boot menu, there is only Windows. I'm on UEFI and secure boot is enabled - it wont let me disabled it in the options.

Prior to that, everything used to work just fine. I'm confused!

  • EDIT : Problem fixed, see my answer.

marked as duplicate by Eric Carvalho, Fabby, waltinator, user68186, Elder Geek Mar 19 '18 at 16:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

0

Boot-Repair may help you. Information can be found here: https://help.ubuntu.com/community/Boot-Repair

0

Well I'm going to answer my own question since I've figured out the solution. It appears that on ACER Laptops, one must indicate an EFI file in the boot options. Here's how I did it :

  • Boot the computer and press F2
  • Define a password in Securty tab so that you can access options
  • Go to "select an uefi as trusted for executing"
  • Select HDD0 -> EFI -> Ubuntu -> shimx64.efi
  • Enter the description you wish in the following pop-up

  • Reboot

  • Press F2 and go in the boot tab
  • Put EFI File Boot 0 :.... in first
  • Save and exit.

Not the answer you're looking for? Browse other questions tagged or ask your own question.