7

I recently installed the Firefox snap package (originally announced here).

Aside from lacking global menu / locally integrated menu support, everything is working flawlessly. However, the snap package doesn't include the Adobe Flash plugin.

The following are the only two extensions that come bundled in the snap:

  • OpenH264 Video Codec provided by Cisco Systems, Inc.
  • Widevine Content Decryption Module provided by Google Inc.

As this is the first snap app I've installed, I'm not familiar with the directories where extensions are installed, or how to go about installing them. Any help would be greatly appreciated. Thanks!

  • I'm not sure how to install the plugin in Firefox, but perhaps I could help you install it on your machine in general? – NerdOfCode Mar 16 '18 at 4:29
  • I have it installed on my machine, and it works fine in the version of Firefox that is updated in Ubuntu's repos. However, it is not accessible in the snap. – PC_LOAD_LETTER Mar 16 '18 at 4:32
  • Oh alright! Sorry, for not being able to help ! – NerdOfCode Mar 16 '18 at 4:33
  • No worries. I appreciate the response! – PC_LOAD_LETTER Mar 16 '18 at 4:35
  • 1
    My guess, without any proof, is that you can't. A lot of content is available as HTML5 although there are hold-outs still using Flash. Anyway, please keep your question updated with what you find and in case you do find a solution to your question, please post an answer. A lot of people would be interested! – DK Bose Mar 16 '18 at 4:44
3

Pretty simple, Mark Johnson had it correct but he deleted. The way I always install flash is to go here - https://get.adobe.com/flashplayer/otherversions/

In the drop downs choose linux & the .tar.gz for for NPAPI. Extract the download, copy libflashplayer.so to ~/snap/firefox/common/.mozilla/plugins folder, creating that plugins folder as it won't exist.

That's it. One can go to the about:plugins URL to see if it is up-to-date. If it complains that it's out-of-date (or a website you visit complains that it's out-of-date), just follow the same procedure to update it

Shockwave Flash appears in the Plugins section

  • This works. I was struggling away with the adobe-flashplugin package before coming across this answer. Just to add that you don't need to copy the /usr files as recommended in the extracted readme.txt file – Ubuntu_enthusiast Oct 11 '19 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.