3

Important: this question How to disable microphone from auto adjusting its input volume doesn't cover this scenario.

This question is about the volume auto adjust feature of pulseaudio "module-echo-cancel".


I am using the pulseaudio module module-echo-cancel, officially documented here.

You can enable it by editing /etc/pulse/default.pa and adding the line:

load-module module-echo-cancel

And reseting it with pulseaudio -k. And it works.

But the documentation doesn't inform how to disable the volume auto adjust that this module executes when it is enabled.

3
load-module module-echo-cancel aec_args="analog_gain_control=0 digital_gain_control=0"

Source: https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Enable_Echo.2FNoise-Cancelation

  • You really searched deep! Congratulations! – Paulo Coghi Aug 29 '18 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.