1

I'm currently making a switch from my old Macbook to a new and shiny Ubuntu (Purism) Laptop. Things go pretty well, but I'm having trouble selecting text in the terminal.

When I'm in a text in any normal program (browser, LibreOffice or any other text editor) I often want to select text using my keys instead of the mouse. To do that I can hold Shift and then use the arrow keys to move left or right to select the text that I want. When I want to do the same, but select per word (which goes a lot quicker) I hold Ctrl+Shift and then select the words that I want using the left and right key. This works perfectly.

I now want to do the same in the terminal, but I can't get it working. When I hold just the Ctrl key and move left and right it jumps words like I expect it to. But when I then hold the shift, if simply prints a D for the left arrow key and a C for the right arrow key.

Does anybody know why this is? And more importantly, does anybody know how I can get the behaviour I want where Ctrl+Shift+Left selects the word left of the cursor in the terminal?

  • Doesn't Purism ship with PureOS and not Ubuntu? – DK Bose Mar 15 '18 at 14:42
  • From the help (help.gnome.org/users/gnome-terminal/stable/…), all options require a mouse. Or you can use screen/tmux. – muru Mar 15 '18 at 14:43
  • @DKBose - Yes, but I wiped it and installed Ubuntu. I like to run the same as on my servers.. :-) – kramer65 Mar 15 '18 at 14:45
0

According to Thanatos on SuperUser Stack Exchange it looks like it is not possible to do that with the default gnome terminal.

There is nothing about word selection shortcuts in the gnome terminal preferences.

Please see this answer for further information.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.