0

After logging in to my system, the dash, top panel and title bars of windows are not being displayed. I tried opening dash by pressing the window key but it was of no use.

On my desktop, I had two shortcuts to some folders I use regularly. Using it I was able to open the nautilus explorer which let me realize that also the title bars are not being displayed.

Despite the comment at the start of this answer, I tried it never the less. Surprisingly, it seems compizconfig-settings-manager was already installed on my system and the Ubuntu Unity Plugin and Enable OpenGL checkboxes were already checked. I may have installed it when this system used to be an older version of Ubuntu but I don't remember doing it.

I also tried the following (again expecting it to work against all odds).

unity --replace

But the issue persists.

I thought of trying to get a screenshot but it would just have been my wallpaper with the two icons or maybe the title bar less window of nautilus. I don't think it would have helped anyway.

This system used to be 14.04 which I had then upgraded to 16.04. It used to work fine up until yesterday. I don't know what happened now.

Really need help with this :(


Update #1

As I mentioned, I've already tried most of the solutions given against this question; None helped.

  • Did you try to reset the Unity and/or Compiz configurations like some of the answers to the linked question suggest? – David Foerster Mar 17 '18 at 10:34
  • David Foerster - Yeah... No change... And given that this question has been marked as a duplicate of a 7-year-old question that the one asking the question did try, I'm not optimistic that I'm gonna find a solution here... Thanks for all the help... – Bilesh Ganguly Mar 17 '18 at 10:55
  • Could you please try to create a new (temporary) user account and log into that with a Unity session? Does that change anything? – David Foerster Mar 17 '18 at 11:00
  • It would be very effective if you would be so kind as to edit your post to tell us exactly which solutions you tried and in which order if possible. Did you perhaps try askubuntu.com/a/73726/225694 or askubuntu.com/a/827296/225694 I realize these are pretty far down the list of answers and you may not have reached that point. – Elder Geek Mar 24 '18 at 13:25
-2

I have the same problem. Check this thread for fixes people have tried. Some of them seem to work for some people. But not for all. The problem is still unsolved and pending.

Ubuntu Forums

1.) I tried to clear the cache as suggested (terminal -> sudo rm -r ~/.cache), but i did not work for me.

2.) I tried to login as a guest, but the screen is still blank and i had to open console one by ctl+alt+F1 and sudo reboot.

3.) Opening a terminal by right click and then unity --reset or unity --reset-icons did not work either. As of 3.) i get error messages in terminal, as is:

compizconfig - Error: Unable to find interface type 3 on 0x10065b0 [... ] unity-panel-service stop/waiting unity-panel-service start/running process 2798 start: Job failed to start

I am out of ideas now, as im not an expert for unity or desktop GUIs in general.

Need help with this too! I need my Computer/GUI...


UPDATE

Finally i found a solution, that worked for me (Ubuntu 16.04.04 LTS) !

rm -rf ~/.compiz-1 ~/.config/compiz-1

sudo shutdown now

reboot PC

Keep in mind this will delete your Dash customization :( But at least Dash and Menus are back now!

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Melebius Mar 15 '18 at 13:10
  • I blockquoted, what did not work for me, but may work for others. – JackEdgewood Mar 15 '18 at 13:26
  • Wait, even the author stated it did not help? Then we probably don’t need the contents here. – Melebius Mar 15 '18 at 13:29
  • For some the cache reset did work. For me, it did not work. – JackEdgewood Mar 15 '18 at 17:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.