0

I know there are a lot of already asked questions in the web concerning plex server and ubuntu but none of the solutions worked for me. I am using ubuntu 16.04 LTS clean install. I installed plex media server to which I have access via web browser so I think this works fine. Since all my media files are on diffrent NAS, I need to mount these. For this I created a folder in my home directory /home/video/movies to which I assigned

sudo chown -R username:plex /home/video/movies
sudo chmod -R 770 /home/video/movies

to mount I added the following line to my /etc/fstab file:

//static_ip_to _nas/movies    /home/video/movies  cifs  uid=1000,username=yyy,password=xxx,vers=2.0

I tried diffrent setups with adding gid,rw and so on but the posted setup showed the best result considering write access. But when I try to add a mediafolder to plex via webbrowser plex is not doing anything. When I check the permissions of the mounted movies folder there is no plex user shown even it was shown before mounting the NAS. I also tried the uid from the plex user for the fstab file but this didn't work eather. The second problem is the second NAS which is also a QNAP NAS like the first one only a newer version. When I set the same command like above for the second NAS and run sudo mount -a I get an error that this action is not supported. Why is this and how can I succesfully add my mediafolder to plex?

UPDATE:

before mount

ls -la /home/max/video/movies

total 8
drwxrwxr-x 2 770 plex 4096 Mär 14 20:05 .
drwxrwxr-x 3 770 plex 4096 Mär 14 20:05 ..

after mount

ls -la /home/max/video/movies

total 180
drwxr-xr-x 2 max root      0 Mär 12 21:17 .
drwxrwxr-x 3 770 plex   4096 Mär 14 20:05 ..
drwxr-xr-x 2 max root      0 Nov 10 14:01 movie1
drwxr-xr-x 2 max root      0 Feb 20 17:20 movie2
.
.
.

The error message I'm getting while mounting the second NAS is:

mount: mount //192.168.178.5/Max/Video/Mediathek/Movies on /home/max/mediathek/video/movies failed: Operation not supported

Is it possible that the error has something to do with port bundling of the NAS?

  • Can you add a bit more information: error massages of the mount /home/video/movies command, ls -la /home/video/movies befor and after the mount, etc... – Simon Sudler Mar 14 '18 at 9:53
  • I updated the requested information – Max2603 Mar 14 '18 at 20:35
  • I don't think, it has something to do with port bundling or the mods/users. Try setting the CIFS version. – Simon Sudler Mar 14 '18 at 20:59
  • Do you have any idea about the other problem, I mean that plex won't find any media in the mounted directory? – Max2603 Mar 15 '18 at 21:12
  • Let's fix the mount issue first... I assume they are related – Simon Sudler Mar 16 '18 at 7:59
0

This is just a wild guess, but I had a similar issue with a NAS and the CIFS version. Try to specify the version of the CIFS in /etc/fstab (and also start with read-only for testing):

//nas_srv/folder /mnt/folder cifs uid=1000,username=yyy,password=xxx,vers=1.0,ro
  • I tried this but I only recive this message: mount: wrong fs type, bad option, bad superblock on //192.168.178.5/Max/Video/Mediathek/Movies, missing codepage or helper program, or other error (for several filesystems (e.g. nfs, cifs) you might need a /sbin/mount.<type> helper program) In some cases useful info is found in syslog - try dmesg | tail or so. – Max2603 Mar 15 '18 at 21:08
  • did you check the syslog and dmesg? – Simon Sudler Mar 16 '18 at 7:47
  • okay, it seemed like I was using an unsupported samba version. I am now able to mount all my NAS shares. But still plex wont find any media in the mounted directories – Max2603 Mar 16 '18 at 8:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.