1

I have referred this Link. According I have followed the instruction and disabled the shortcut keys and checked in dconf-editor it was disabled but the thing is that still shortcut keys are working fine on my end. I'm using Ubuntu VM 16.04.

gsettings list-recursively | grep move-to | grep -v disabled

org.gnome.desktop.wm.keybindings move-to-workspace-6 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-8 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-9 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-7 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-5 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-10 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-11 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-12 @as []
org.gnome.desktop.wm.keybindings move-to-center @as []
org.gnome.desktop.wm.keybindings move-to-workspace-right ['<Shift><Control><Alt>Right']
org.gnome.desktop.wm.keybindings move-to-workspace-up ['<Shift><Control><Alt>Up']
org.gnome.desktop.wm.keybindings move-to-workspace-left ['<Shift><Control><Alt>Left']
org.gnome.desktop.wm.keybindings move-to-workspace-down ['<Shift><Control><Alt>Down']
org.gnome.desktop.wm.keybindings move-to-workspace-1 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-2 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-3 @as []
org.gnome.desktop.wm.keybindings move-to-workspace-4 @as []

dconf dump / | grep move-to | grep -v disabled

move-to-workspace-left=['<Shift><Control><Alt>Left']
move-to-workspace-down=['<Shift><Control><Alt>Down']
move-to-workspace-up=['<Shift><Control><Alt>Up']
move-to-workspace-right=['<Shift><Control><Alt>Right']

I have tried:

dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-w "['disabled']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-s "['disabled']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-n "['disabled']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-e "['disabled']"

dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-w "['']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-s "['']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-n "['']"
dconf write /org/compiz/profiles/unity-lowgfx/plugins/resize/move-to-side-e "['']"

I have tried the above code. It was not disable but using compizconfig-settings-manager ->Window Management -> Grid unselected the checkbox now it was disabling the shortcut key. I don't want to disable it using GUI or Should I change anything in Compiz profiles - unity and unity-lowgfx.Please advise me, if any alternative solution for this.

1
  • 1
    I think you should check output of two commands gsettings list-recursively | grep move-to | grep -v disabled and dconf dump / | grep move-to | grep -v disabled then add it to your question. – N0rbert Mar 14 '18 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.