Since I upgraded to Xubuntu 16.04 every time I lock the screen I get a black screen (with a white dash cursor in the top left corner) and there's nothing I can do to unlock it (I've tried Ctrl-Alt-F1 and Ctrl-Alt-F7 but nothing happens), except hard reboot.

Do you have suggestions to solve (or debug) this issue ?


To debug

  • Install accountsservice and xserver-xephyr, where:
    • accountsservice for Enhanced user accounts handling.
    • xserver-xephyr for LightDM test mode.

Then run LightDM as an X application for debugging: lightdm --test-mode --debug

  • LightDM's log file is /var/log/lightdm/lightdm.log, you will need root privilege to view it.
  • Or see output of dmesg with sudo dmesg.

List of workaround methods

  • Try to suspend and resume again

    Press CtrlAltF1, then login and type systemctl suspend. Press power button to resume and switch to tty7 by CtrlAltF7. In my case, I did 2 times to escape the blank screen.

  • Use DRI2 instead of DRI3 may solve the problem: https://wiki.archlinux.org/index.php/intel_graphics#DRI3_issues

  • Disable at-spi-dbus-bus.desktop (may NOT work)

    sudo mv -v -i /etc/xdg/autostart/at-spi-dbus-bus.desktop /etc/xdg/autostart/at-spi-dbus-bus.desktop.disabled

  • Replace light-locker with xscreensaver, then reboot.


  • Replacing lightdm with xscreensaver actually worked.
    – sdabet
    Mar 22 '18 at 17:05

Well, sudo apt-get install --reinstall xscreensaver may do the work for you. If this doesn't work try sudo apt-get purge --auto-remove xscreensaver && sudo apt-get install xscreensaver.


On xubuntu 18 I used to get blank screen after locking and pressing keys did not help except

ctrl + alt + F7. On this combination I was seeing something like this session is locked you'll be redirected few seconds. And then I was able to see.

Then I read there How to unlock locked session? and executed this:

sudo apt-get update && sudo apt-get install xscreensaver && sudo apt-get remove light-locker

it did not help.

Then I searched for my screen saver gui settings and disabled screen saver. Then on locking screen I see this weird xscreensaver window, but its much better than blank screen and need pressing ctlr + alt + F7


For a quick remedy, it would be enough to kill light-locker:

    killall light-locker

from the console #1 (Ctrl+Alt+F1). Then, after you switch back to the console #7 (Ctrl+Alt+F7) the lock screen disappears. Worked for me on Xubuntu 18.04.


In Xubuntu 18.x and Ubuntu XFCE 19.04, 19.10 (XFCE4, lightdm) I experience the un-lock screen does not show up. The screen remains locked!

Actually typing the password into the invisible lock sceen OPENS the lock!!!

That means the password request is working but does not show up. This is the reason why there are no error messages.

QUESTION: How can I make the password request visible??


When I experience this problem, I press ctrl + alt + del, then enter the password again and somehow it fixes it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.