1

Can anyone help me, I cant log-in to my laptop. Looks like its just looping back to the login screen.

What may have caused it, I was downloading a dataset from Kaggle. Then I had to open the terminal and and type chmod 600 ~/.kaggle/kaggle.json (as shown here), I got an error so I put sudo chmod 600 ~/ pathname When I ran the second command It couldn't find the path and when I checked my files/folder in home it said "You dont have the permission to access these files". I have tried the following methods from AskUbuntu forum:

  1. Can't log in my ubuntu laptop, login loop
  2. Ubuntu stuck on login screen

But the problem still exists. After using the first method I see the following output on my terminal

(Image 1)

but I am still stuck at the login loop.

EDIT : The image I get after running the this command find ~vat26 ! \( -readable -writable -user vat26 \( ! -type d -o -executable \) \) -ls |& tee /tmp/vat26-permissions.log (as asked by @David Foerster) is this : (Image 2)

1

Boot a live session on your laptop from installation DVD or USB. Within live session in the file manager identify your drive. Open terminal and change directory to your home folder on the drive.

With

sudo chmod 755 /path_to_your_home_folder 

you can fix your file permissions.

Note: path to your home folder will be in the live session like this: /media/disk_UUID/home/username

  • I am just wondering how it can be done without live session. Could you please explain? – kukulo Mar 14 '18 at 6:33
  • If he is still logged in then sudo chmod 755 /home/user_name/ is appropriate. – kukulo Mar 14 '18 at 6:52

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.