2

My default font is Futura Medium. The font displays just fine in all of my other programs and in system dialogues and menus. Recently, however, LibreOffice has been having an error. All of the menus from the panel are displaying Futura Medium just fine, but right-click menus, the File Open dialogue and all mouseover text is just displaying Unicode boxes. The problem persists after reboots.

Here's a screenshot of what I'm talking about

Here's a screenshot of what I'm talking about

I've used Unity Tweak Tool to change my default font, and for all others that I've tried, the problem is fixed. Any idea why Futura (And all of the variants of it that I've tried) are not displaying properly?

Ubuntu 17.10. LibreOffice 5.4.5.1.

  • When you say, "for all others that I've tried, the problem is fixed" do you mean that the fonts display properly instead of being Unicode boxes? – RonJohn Mar 14 '18 at 0:43
  • Maybe related to askubuntu.com/questions/1000231/… ? – DK Bose Mar 14 '18 at 1:31
  • @RonJohn Yes, sorry if that wasn't clear. I've changed my default font to several other installed fonts. Every other one I've tried has displayed properly in the file open dialogue in LibreOffice. The only font I've found to have this problem on my system is Futura. – Gerardicus Mar 15 '18 at 0:56
  • @DKBose It seems like that may be the same, or at least a similar problem. I can't get any fonts in the Futura family to even show up under formatting in LibreOffice. Considering I don't know how to convert the ttf into otf, should I create a new thread for that question? – Gerardicus Mar 15 '18 at 1:13
  • @DKBose Futura seems to be a TTF. They're ditching all the ancient Type 1 fonts. – RonJohn Mar 15 '18 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.