When trying to install curl on Ubuntu 16.04, it gives me the following error message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
curl : Depends: libcurl3-gnutls (= 7.47.0-1ubuntu2) but 7.47.0-1ubuntu2.6 is to be installed
E: Unable to correct problems, you have held broken packages.

How to fix?

  • 1
    Do sudo apt update; sudo apt-get upgrade helps ? Mar 13, 2018 at 17:02
  • Please add the output of apt policy curl libcurl3-gnutils to your question.
    – Byte Commander
    Mar 13, 2018 at 17:06
  • How about apt install -f?
    – NerdOfCode
    Mar 13, 2018 at 17:53
  • The output is: curl: Installed: (none) Candidate: 7.47.0-1ubuntu2 Version table: 7.47.0-1ubuntu2 500 500 us.archive.ubuntu.com/ubuntu xenial/main amd64 Packages N: Unable to locate package libcurl3-gnutils
    – Wallace
    Mar 13, 2018 at 18:03
  • Wallace : Did you forget sudo apt update ? I.e. latest is curl 7.47.0-1ubuntu2.6 , not 7.47.0-1ubuntu2 → packages.ubuntu.com/xenial-updates/curl Mar 13, 2018 at 18:24

2 Answers 2


UPDATE: I fixed the problem by reverting to an older version of libcurl3-gnutls.

For anyone who is having the same problem, I did this by listing the cache:

apt-cache showpkg libcurl3-gnutls    

Which gave me a long output, but the important part was the last three lines:

7.47.0-1ubuntu2.6 - 
7.47.0-1ubuntu2 - 
Reverse Provides: 

I used the following command to download the older version:

sudo apt-get install libcurl3-gnutls=7.47.0-1ubuntu2

Then I ran sudo apt install curl as normal.

Thanks for the help!

  • I'm getting Version '7.47.0-1ubuntu2' for 'libcurl3-gnutls' was not found error
    – Harshal Y.
    May 1, 2019 at 8:30

I experienced something similar but the fix suggested above didn't work. What finally fixed it for me was to do: sudo apt remove libcurl4 then I could do sudo apt upgrade without getting error messages about unmet dependencies for libcurl.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.