I know this looks like a question that must've already been answered, but I've looked everywhere for a solution.

I'm running ubuntu 17.10 on an 80-key dell Inspiron 11 and I'm trying to add the Latinamerican ("latam") keyboard layout alongside my en (US). The settings GUI lets me add the Spanish ("es") keyboard without a problem, but that has the accent keys in different places. The latam keyboard doesn't show up in the GUI. This wasn't a problem in 16.04.

I've played around with /etc/default/keyboard and dpkg-reconfigure keyboard-configuration, but I haven't gotten them to stick. I also plan on adding a few more layouts, but the most important are en and latam. Thanks!

  • It would help if you showed us an example of the desired keyboard layout, e. g. through a Wikipedia link or similar. You can also display a graphical representation of each keyboard available in Ubuntu through the input method configuration dialogue. (Please edit your post when you want to clarify something or add information? It’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons.) Thanks. – David Foerster Mar 13 '18 at 14:49
  • I approved your proposed edit of my answer, but reversed it afterwards since it didn't clarify anything. If you need a clarification, please ask for a clarification in a comment on the answer at first hand. – Gunnar Hjalmarsson Mar 13 '18 at 18:15
  • @DavidFoerster: It's possible that your comment confused the OP. Please consider to edit or remove it. The question is crystal clear IMO. – Gunnar Hjalmarsson Mar 13 '18 at 18:21
  • @GunnarHjalmarsson: It's not entirely clear to me if OP and I think of the same keyboard layout when he says "Latinamerican ('latam')". – David Foerster Mar 13 '18 at 18:23
  • @DavidFoerster: There is only one 'latam' layout in XKB. (But the GUI seems to be a mess; see my edited answer.) – Gunnar Hjalmarsson Mar 13 '18 at 19:09

It's there. If you click a Latin American country, e.g. Spanish (Argentina), you are taken to a sub menu which includes Spanish (Latin American).


I happened to have the Spanish language installed, and under that condition the above advice applies. However, if you want to enable the Spanish (Latin American) keyboard layout without installing the Spanish language, you can add some Latin American locale. Open a terminal window and run for instance:

sudo locale-gen es_AR.UTF-8

Now, if you open Settings -> Region & Language and select Spanish under Input Sources, the sub menu you are taken to will include Spanish (Latin American).

The design makes no sense. Keyboard layouts should not have anything to do with which locales you happen to have generated. Personally I think this a design bug which should be reported to the GNOME developers.

Issue submitted: https://gitlab.gnome.org/GNOME/gnome-control-center/issues/82

  • 1
    Great tip! That command made it start showing up in my list and now I've got my beloved latam keyboard back! – Jeff Mar 15 '18 at 0:28
  • @Jeff: Great to hear that it worked for you. Can you please accept my answer then by clicking the gray check mark to the left of the answer. That would mark your question as resolved. – Gunnar Hjalmarsson Mar 15 '18 at 9:04

I guess your keyboard is in English.

I used to have English keyboard with Spanish(Latin American keyboard). But now, a much simpler way is to use English (US with dead keys), you can simple use the accents with ease, for example:

  • ñ = n + alt

  • á = ' + a

  • e = ' + e

    And so forth.

This way you don't need to switch keyboards.

The way to install more inputs works for me in the following screen:

enter image description here

  • Thanks for the recommendation, but I've used the latam keyboard for many years and I'm already used to all the different remappings. I also frequently use other keyboards (here in Chile) and they're all latam. – Jeff Mar 13 '18 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.