1

First at all, I know that this question is duplicate, but I have tried every solution of all the other "compiz/unity issue after upgrading 16.04 LTS" questions with no luck. I have been hours trying things and in the end I have switched to Gnome with metacity to be able to work a bit.

To be honest, I think I have the same problem that this question:

Unity Top Bar and Launcher disappeared Feb 24/2018

but I can't post a comment there and I can do a new question (weird, isn't it?). I have tried all the things Samvid tried except downgrading Mesa (I have not it installed) and still nothing.

That question remains unsolved and communication finished the 3rd of March, so I wonder if there is any other solution not documented there.

If you need any data of my computer, please ask it. I'll be happy to help.

Thanks in advance.

PS: I suspect that the solution to this bug 2/15/18 compiz update broke unity is what has broken my current version.

PS 20180313: Not sure if it is because I have applied the answer of N0rbert, but now i have tried (for sixth or seventh time) the "setsid unity" command in a terminal of a metacity session and after rebooting I have Unity and Compiz (with reset values) working again! Thanks a lot

  • I think that the fix to that question has broken another thing that is my current issue. @~$ sudo apt-cache show compiz-core Package: compiz-core Architecture: amd64 Version: 1:0.9.12.3+16.04.20180221-0ubuntu1 Provides: compiz-core-abiversion-20180221 – daniel.merino Mar 12 '18 at 13:24
  • Don't know if you've tried it yet but four people have had luck with this fix: askubuntu.com/questions/1007026/… – WinEunuuchs2Unix Mar 12 '18 at 15:42
  • Thanks. Yes, I had tried that. Anyway, I have tried it again and nothing. The issue persists. – daniel.merino Mar 13 '18 at 7:00
0

Update package lists and packages:

sudo apt-get update
sudo apt-get dist-upgrade

Then reinstall all compiz-related stuff with:

sudo apt-get install --reinstall compiz compiz-core compiz-gnome \
compiz-plugins compiz-plugins-default compizconfig-settings-manager \
libcompizconfig0 python-compizconfig

And then reinstall ubuntu-desktop-related stuff:

sudo apt-get install --reinstall a11y-profile-manager-indicator gir1.2-unity-5.0 \
hud libhud2 libaccount-plugin-1.0-0 \
libunity-action-qt1 libunity-control-center1 libunity-core-6.0-9 libunity-misc4 \
libunity-webapps0 libunity-scopes-json-def-desktop \
libunity-gtk2-parser0 libunity-gtk3-parser0 libunity-protocol-private0 \
qml-module-ubuntu-components qml-module-ubuntu-layouts qml-module-ubuntu-onlineaccounts \
qml-module-ubuntu-performancemetrics qml-module-ubuntu-test qml-module-ubuntu-web \
qtdeclarative5-ubuntu-ui-toolkit-plugin qtdeclarative5-unity-action-plugin \
ubuntu-session ubuntu-ui-toolkit-theme unity unity-accessibility-profiles \
unity-lens-applications unity-lens-files unity-lens-music unity-lens-photos \
unity-lens-video unity-schemas unity-scope-calculator unity-scope-chromiumbookmarks \
unity-scope-colourlovers unity-scope-devhelp unity-scope-firefoxbookmarks \
unity-scope-gdrive unity-scope-home unity-scope-manpages unity-scope-openclipart \
unity-scope-texdoc unity-scope-tomboy unity-scope-video-remote unity-scope-virtualbox \
unity-scope-yelp unity-scope-zotero unity-scopes-master-default unity-scopes-runner \
unity-services unity-webapps-common unity-webapps-qml unity-webapps-service unity-settings-daemon \
libunity-settings-daemon1 unity-control-center unity-control-center-faces \
unity-control-center-signon unity-greeter unity-gtk-module-common unity-gtk3-module

And finally:

sudo apt-get install --reinstall ubuntu-desktop
| improve this answer | |
  • Thanks ,but I have tried this and my issue persists. Please ask me if you need to know any data. – daniel.merino Mar 13 '18 at 6:52
  • Not sure if it is because of this change, but i have tried (for sixth or seventh time) the "setsid unity" command in a terminal of a metacity session and after rebooting I have Unity and Compiz (with reset values) working again! Thanks a lot – daniel.merino Mar 13 '18 at 13:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.