0

When I try to install the graphics driver it shows the following error message. I also tried fixing the broken package but it didn't work.

$ sudo apt-get install nvidia-390
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nvidia-390 : Depends: lib32gcc1 but it is not going to be installed
              Depends: libc6-i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages

if this might help, here is some info about my current system

dpkg --print-architecture amd64

nashib@nashib-Vostro-5470:~$ dpkg --print-foreign-architectures i386

nashib@nashib-Vostro-5470:~$ apt-cache policy nvidia-390 lib32gcc1 libc6-i386 nvidia-390: Installed: (none) Candidate: 390.25-0ubuntu0~gpu16.04.1 Version table: 390.25-0ubuntu0~gpu16.04.1 500 500 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial/main amd64 Packages lib32gcc1: Installed: (none) Candidate: 1:6.0.1-0ubuntu1 Version table: 1:6.0.1-0ubuntu1 500 500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages libc6-i386: Installed: (none) Candidate: 2.23-0ubuntu3 Version table: 2.23-0ubuntu3 500 500 http://archive.ubuntu.com/ubuntu xenial/main amd64 Packages

3
  • 1
    Try different driver version like nvidia-384. Mar 12, 2018 at 11:19
  • it also shows the same message Mar 12, 2018 at 11:21
  • Could you please edit your question to include the output of dpkg --print-architecture, dpkg --print-foreign-architectures, and apt-cache policy nvidia-390 lib32gcc1 libc6-i386? Thanks. Mar 12, 2018 at 11:44

1 Answer 1

-1

Open the Software and Updates app. Click on the Other Software tab, check the Canonical Partners checkbox, enter your password when prompted. Then click on Close then on the Reload button. It will update the cache then close. Launch it again, click on the Addition Drivers tab. It will search for any drivers that it can find. If your WiFi adaptor is supported, it will come back with driver options for you to select. Choose one then click on Apply Changes

1
  • i just did it, everything goes fine but when i tried to apply changes after selecting driver, it automatically revert to the default one. Mar 12, 2018 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.