1

I am using Ubuntu 17.10 and recently I started having a wifi connection problem at a local ISP (wispotter) hotspots.

Normally after connecting to this open wifi, I was redirected to a login portal but starting from last week (I don't remember changing any of my configs), I started having a problem.

When I try to connect open wifi, my computer optains and IP address but wifi connection status stay at question mark (?)

enter image description here

enter image description here

I will appreciate any kind of support to solve this issue.

6
  • After I read this blog, I managed to solve the problem: lguruprasad.in/blog/2015/07/21/…
    – Tolga
    Mar 12 '18 at 7:44
  • I wonder why I started having this issue which I didn't have before for that reason I am not sure if my problem is related with the "captive portal handling" or not?
    – Tolga
    Mar 12 '18 at 7:46
  • Do you know whether "captive portal handling" is enabled by default or not on Ubuntu 17.10?
    – Tolga
    Mar 12 '18 at 7:46
  • It should be as per this: omgubuntu.co.uk/2017/07/ubuntu-17-10-work-captive-portal-wifi Anyway, it would help if you can post a detailed answer from the link that helped you so that others may find this Q&A helpful in future.
    – pomsky
    Mar 12 '18 at 8:13
  • Hi pomsky, I am not sure what was the root cause of the problem and what is the solution. For that reason I hesitate to post my solution.. As I mentioned above; I was able to connect to the same wifi without any problem until last week (I mean, I didn't have issue with the "captive portal handling". And today I was able to connect again by following the procedure described at: "Enabling captive portal detection in GNOME 3.14 on Debian Jessie". Now, if ubuntu 17.10 by default is unable to handle captive portal automatically, how could I connect this wifi until last week??
    – Tolga
    Mar 12 '18 at 9:58
1

After I read this blog, I managed to solve the problem following the procedure below: https://www.lguruprasad.in/blog/2015/07/21/enabling-captive-portal-detection-in-gnome-3-14-on-debian-jessie/

Problem seems to be related with enabling the "captive portal handling" in GNOME.

To enable it, create a file /etc/NetworkManager/conf.d/20-connectivity-debian.conf with the following content:

[connectivity]
uri=http://network-test.debian.org/nm
response=NetworkManager is online
interval=300

Then restart NetworkManager using the command:

sudo service network-manager restart 

Once this is done, whenever you connect to a network with a captive portal, GNOME will automatically open the captive portal login page where you can login to get access to the internet. Please note that the requests to the connectivity test URL could be logged and be aware of its privacy implications though no personally identifiable information is sent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.