Have tried several approaches that seem to have worked for others but to no avail. Have a Realtek RTL8188EE controller, as the title of this question states, have tried numerous approaches suggested to be a fix via askubuntu. None seem to work. Namely this method, and this both of which involve invoking a systemd script to restart the network-manager.servic via script. Running the sudo systemctl commands in terminal 'manually' also fails to init the network service(s)

Unlike some other question(s) descriptions, this problem is not intermittent, both "Enable Networking" and the "Enable Wifi" selections are removed from their respective menus upon resume from suspend.

Any help with this is greatly appreciated, as I have had move between multiple locations lately, and each time I do so I must waste time and attention restoring the workspaces I utilized before I had to power down if I want to have internet access.

  • This might provide some clues: askubuntu.com/questions/898297/… – WinEunuuchs2Unix Mar 11 '18 at 23:27
  • Some good information in there with regards to other hardware, tried a few of the solutions proposed and still nothing solved here. The RTL8818EE controller I have does not seem to respond to the Intel specific 'iwlwifi' controller calls at all. Same problem I had with Wifi remaining disabled still. Both the Automatic and the Manual method seem not to make any difference. – lexparsimonet Mar 14 '18 at 22:14
  • replace intel driver names with realtek ones... – WinEunuuchs2Unix Mar 14 '18 at 22:25
  • I originally misinterpreted the iwlwifi namespace as being a generic directory or filename, I did try the rtl8188ee correct driver namespace brosef gandalfini - but to no avail. The manual implementation of the solutions answer that you posted in your comment functions properly when the system has not been suspended, but does not reinitialize the wifi driver post suspend. Scratching my head on this, NetworkManager seems to restart, the taskbar/menu selections appear for Enable Networking and Enable Wifi but still no connection. Thanks for your input/help all the same! – lexparsimonet Mar 16 '18 at 0:38
  • My only suggestion would be to try the most recent LTS kernel: `4.14.27. See: askubuntu.com/questions/119080/… – WinEunuuchs2Unix Mar 16 '18 at 1:05

I am experiencing the same issue with a different wifi network controller, but I have found an easy fix for me. I assume that you're using a notebook of some sort, too? Mine has a switch with which I can manually turn on or off the Wifi and other wireless connections (like Bluetooth), for airplane mode. I found out that using this switch to turn off the wifi and then turn it on again after a second makes Ubuntu restore the wifi connection.

  • Please don't repost the same answer to multiple questions. – Thomas Ward Mar 13 '18 at 3:06
  • Tried my notebooks 'airplane mode' function key, also does not restart wifi. Seems to affect NetworkManager only if the system has not been started from suspend. Rebooting entirely is the only thing that works so far. Also, @ThomasWard don't know where 0x01 is reposting, but your comment is even less helpful. – lexparsimonet Mar 16 '18 at 0:41
  • I think I'm supposed to mark answers as duplicate instead of reposting answers. I'm new. Just wanted to pass on what worked for me to others. – 0x01 Mar 16 '18 at 5:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.