1

I'm trying to route internet traffic through my vpn. I've set up everything using a tutorial. Now, I've heard that OpenVPN can only handle either ipv4 OR ipv6. So I wanna stick with ipv4. I disabled ipv6 in the network manager on my pc, but now, ipv6 websites are still sent over ipv6 without the VPN. How can I prevent this?

Thanks!! :)

1

If you don't mind disabling IPv6 entirely then you could try this answer here.

Do ifconfig first and check if you still have an IPv6 address, if you do then it's still active, if not then something else is going on...

There is always 1 IPv6 address, ignore the fe80 one, if you have a second then it is still active. enter image description here

You could also trying pinging an ipv6 address to see if you still get a reply

ping6 2607:f8b0:4003:c00::6a

| improve this answer | |
  • hm, i have another IPv6 address. but the one from my ISP. Is there no way to disable it on both, my pc and mobile? :) Just so all network traffic is routed over the vpn? I mean, that's what the vpn is for. – Uwe Pfeifer Mar 11 '18 at 10:58
  • If you're looking to route more devices than just your PC then maybe looking into setting up a VPN on your router will be more appropriate? It's also possible you could disable IPv6 on your router. – Hugo Mar 11 '18 at 11:04
  • no i have openvpn on my server. ubuntu 16.04. i have both of my devices connected to the vpn its just the problem, that ipv6 is used, instead of ipv4 for surfing the internet ;D – Uwe Pfeifer Mar 11 '18 at 11:05
  • Yes, so if you still have an IPv6 address as you mentioned earlier try following this guide to disable it. – Hugo Mar 11 '18 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.