1

I tried the following command:

sudo apt-get install libpcl-dev

It is giving the following error:

dpkg: error processing archive /var/cache/apt/archives/libpcl-
dev_1.7.2-14build1_amd64.deb (--unpack):

trying to overwrite '/usr/include/pcl-1.7/pcl/for_each_type.h', which is
also in package libpcl-common-1.7-dev 1.7.2-1+trusty6 
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libpcl-dev_1.7.2-14build1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I do not have any clue how to resolve the issue. Please help.

  • Suggest : Remove the old Ubuntu 14.04 (trusty) libpcl* packages, and then install the Ubuntu 16.04 libpcl-dev – Knud Larsen Mar 11 '18 at 9:13
  • Will it not cause any kind of unmet dependency issues for other packages(such as openCV) which were installed in 14.04? I have upgraded from 14.04 to 16.04. – Sonu Patidar Mar 11 '18 at 13:50
  • You can try $ sudo apt remove libpcl-common-1.7-dev ... and watch if OK. Usually you will have to confirm ( Yes / no ). ... Why do you want "libpcl-dev"? I.e. same version as the 14.04 package. – Knud Larsen Mar 11 '18 at 19:42
  • It is giving me several errors like: libpcl-features-1.7-dev : Depends: libpcl-common-1.7-dev but it is not going to be installed. Can you tell me why these two are having conflicts? – Sonu Patidar Mar 12 '18 at 5:45
  • libpcl-features-1.7-dev is another old package. Not available any more. Was once available (for a short time) for Ubuntu 14.04 Trusty. Suggest : Remove it. – Knud Larsen Mar 12 '18 at 11:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.