1

I have used this tutorial to dual boot my system using Windows 10 and Ubuntu 16, both on GPT/EFI mode.

First, i installed Windows 10 in EFI mode on my 256GB SSD, then installed Ubuntu 16 in EFI mode on my 2TB HDD. this means that I have 2 EFI partitions on my system, one at the beginning of SSD device and another at the beginning of HDD device.

At the end Grub menu showed up and I chose Linux installation, it booted up, everything was fine. next, i booted up to Windows and it was okay too.

the next time I powered up the system, it automatically booted up to windows without showing the Grub menu.
at the BIOS settings page, it doesn't show the HDD device at all and in Windows, i don't see HDD either. How can I see Grub menu and be able to boot into both OSs?

  • Grub normally installs to first drive, unless you disconnected it. I have yet to get Ubuntu's grub to install to sdb drive. But it still should offer to boot. Is ubuntu in UEFI boot menu? What brand/model system? What video card/chip? May be best to see details, you can run from your Ubuntu live installer or any working install, use ppa version not older Boot-Repair ISO: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info and: sourceforge.net/p/boot-repair/home/Home – oldfred Mar 10 '18 at 21:27
  • i did the installation in the same way i did again, and grub showed ubuntu. but i'm affraid if i boot windows, i end up the same place i did before. – behzad mehrtash Mar 10 '18 at 21:51
  • the drive is not disconnected, the ubuntu is in UEFI boot menu, the model is lenovo legion y720, intel core i7, Nvidia Geforce GTX 1060, an nvme ssd drive and an sata HDD drive. but i haven't done Bootinfo or Boot-Repair. i would do that and post the results. – behzad mehrtash Mar 10 '18 at 21:58
  • Some Lenovo systems have locked boot order setting in UEFI. I would check for that or similar settings in UEFI. Make sure Windows fast start up is off. Usually better to have UEFI fast boot off and UEFI Secure Boot off. Some Lenovo still need work arounds to boot. – oldfred Mar 10 '18 at 22:14
  • I have checked all these settings. fast startup is off, the fast boot is off, secure boot is off and I can change the boot order. but the HDD doesn't appear on boot list. – behzad mehrtash Mar 12 '18 at 7:25
0

This is a common problem when dual-booting with a UEFI BIOS. I had this issue when dual booting with Win7, where Windows would take over from GRUB and automatically boot up every time, once Windows Boot manager was selected. But only if I stayed with Ubuntu would the GRUB boot manager always appear next time. Eventually I found a cure for this by accident rather than design.

To get GRUB back you need to run boot repair after booting up from an Ubuntu live CD or a USB pen drive changing first boot-up device (read howtogeek article about this). Remove pen drive/CD, restart computer and test it. Your GRUB boot manager should return, but don't select Windows option yet when GRUB reappears.

Restart computer and go into BIOS. You probably won't see your HDD as first boot choice (or see it at all under HDD drives). It should be showing with Windows Boot Manager as an option. I found my BIOS had been re-written with Windows Boot manager as first choice instead of my HDD drive seen as the first in Boot Order. What I did was enable security on boot and save settings. Windows 7 doesn't support security on boot so then I could not boot into anything once quitting BIOS. I then powered off my PC, then powered back on going back into BIOS, and this time disabled security on boot. Make sure your other UEFI settings have not been disabled as well - if so enable them again and save. Then reboot. This time GRUB manager returned, and on selecting Windows not only could I boot into Windows, but on restart GRUB returned. Also in my BIOS my HDD was once again showing as first in Boot Order.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.