0

Ubuntu 16.04 desktop running vsftpd windows server 2012 r2 running the standard ftp command line client from WAN windows 10 running the standard ftp command line client from LAN

vsftpd.conf

# Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
#
# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=NO
#
# This directive enables listening on IPv6 sockets. By default, listening
# on the IPv6 "any" address (::) will accept connections from both IPv6
# and IPv4 clients. It is not necessary to listen on *both* IPv4 and IPv6
# sockets. If you want that (perhaps because you want to listen on specific
# addresses) then you must run two copies of vsftpd with two configuration
# files.
listen_ipv6=YES
#
# Allow anonymous FTP? (Disabled by default).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# If enabled, vsftpd will display directory listings with the time
# in  your  local  time  zone.  The default is to display GMT. The
# times returned by the MDTM FTP command are also affected by this
# option.
use_localtime=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may restrict local users to their home directories.  See the FAQ for
# the possible risks in this before using chroot_local_user or
# chroot_list_enable below.
#chroot_local_user=YES
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# Customization
#
# Some of vsftpd's settings don't fit the filesystem layout by
# default.
#
# This option should be the name of a directory which is empty.  Also, the
# directory should not be writable by the ftp user. This directory is used
# as a secure chroot() jail at times vsftpd does not require filesystem
# access.
secure_chroot_dir=/var/run/vsftpd/empty
#
# This string is the name of the PAM service vsftpd will use.
pam_service_name=vsftpd
#
# This option specifies the location of the RSA certificate to use for SSL
# encrypted connections.
rsa_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
rsa_private_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
ssl_enable=NO

#
# Uncomment this to indicate that vsftpd use a utf8 filesystem.
#utf8_filesystem=YES

pasv_enable=YES
pasv_min_port=10090
pasv_max_port=10100
pasv_address=<public ip>
#pasv_address=192.168.1.2

#userlist_enable=YES
#userlist_file=/etc/vsftp.user_list
#userlist_deny=NO

sending a file from the windows 10 client inside the LAN works ok.

ftp -d 192.168.1.2
connected to 192.168.1.2
220 (vsFTPd 3.0.3)
---> OPTS UTF8 ON
200 Always in UTF8 mode.
User (192.168.1.2:(none)): <username>
---> USER <username>
331 Please specify the password.
Password:
---> PASS <password>
230 Login successful.
ftp> send c:\users\<username>\desktop\testftp.txt
---> PORT 192,168,1,6,196,33
200 PORT command successful. Consider using PASV.
---> STOR testftp.txt
150 Ok to send data.
226 Transfer complete.
ftp: 4 bytes sent in 0.00Seconds 4.00Kbyte/sec.

sending a file from the server 2012 r2 client from outside of the LAN doesnt.

ftp -d <public ip>
connected to <public ip>
220 (vsFTPd 3.0.3)
User (<public ip>:(none)): <username>
----> USER <username>
331 Please specify the password.
Password:
---> PASS <password>
230 Login successful.
ftp> send c:\users\<username>\desktop\test.txt
---> PORT 192,168,10,38,235,162
502 Active FTP not allowed.
---> STOR test.txt
550 Access is denied.

from what I understand the port is aquired by multiplying the 5th octet next to ---> PORT with 256 then adding the 6th octet to that. So the LAN client is connecting on port (196*256)+33 = 50179 While the WAN client is connecting on port (235*256)+162 = 60322

The the minimum set in the config is 10090 While the maximum is 10100

I also put the server into the DMZ which didn't seem to help but i'm not too concerned about that yet. I just want to work out why it's not respecting my passive port range first.

My guess is passive mode, although enabled in the config, is not actually applying. So its still trying to connect in active mode. which works fine inside the lan. But not outside the lan because the port on the WAN client is blocked or not forwarded. Hence having the server in the DMZ doesnt help because its a network change required on the client side not the server.

So... how do I get my ftp server into passive mode when the online suggestions aren't working? Does the client also need to be told to use passive mode? i can't find any ftp cllient launch options for that.

  • In FTP, the server can't decide to use PASV on its own. The client has to request it, and yours isn't doing so. – Joseph Sible-Reinstate Monica Mar 9 '18 at 22:18
0

Oh wow. I finally figured out what my problem was and it was very simple.

listen=NO needs to be changed to YES
listen_ipv6=YES needs to be commented out

Let me explain. These words here:

# Run standalone?  vsftpd can run either from an inetd or as a standalone
# daemon started from an initscript.
listen=NO

Have absolutely nothing to do with the option listen=NO. I'm not sure why the default configuration file is worded like this.

It's better to think of this as listen_ipv4=NO (which is kind of overridden by listen_ipv6=YES)

The reason you want to comment out listen_ipv6=YES is because leaving it will cause the pasv_address directive to not work.

That means the ftp client will be given 0.0.0.0 as the passive address instead of your public IP address.

So you comment out listen_ipv6 but now the server will not be listening at all. To fix this you need to change listen=NO to YES.

Now it all works perfectly. ...Except for internal clients. They are now receiving the external ip address in the pasv response so they can't use passive mode. I'm not too worried about internal clients though. they can use smb.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.