I have connected speakers to the back panel of my computer at work and I would like to have them always enabled (I can switch them off on the speaker casing). However when I connect headphones on the front panel system automatically says that the rear output is unplugged.

I found a solution to disable auto detection with Alsamixer and it works almost ok except the fact that after system restart I need to reconfigure the settings again... How can I set this once and forget about it?

  • 1
    what sound chipset do you have? output of aplay -l
    – stumblebee
    Mar 17, 2018 at 5:13
  • card 0: HDMI [HDA Intel HDMI], card 1: PCH [HDA Intel PCH] and card 2: NVidia [HDA NVidia] but I need to adjust only volume of PCH in fact. Mar 17, 2018 at 8:41
  • Also, keep in mind that changing the settings with alsamixer works fine. The issue I am experiencing is that the system forgets my changes on reboot so I need adjust speaker volume every morning... Maybe not much time but still: would prefer to keep these settings on restart. :) Mar 17, 2018 at 9:11
  • The volume levels are stored in ~/.config/pulse/*device-volumes.tdb You could backup that file in another directory after you have set your volume levels. Then restore that file at login. It probably wouldn't hurt to back up all the files in ~/.config/pulse/
    – stumblebee
    Mar 17, 2018 at 14:04
  • After files have been restored to ~/.config/pulse/ you will need to run killall pulseaudio for the changes to take affect. Pulseaudio will repawn.
    – stumblebee
    Mar 17, 2018 at 14:36

2 Answers 2


hdajackretask is a tool to reassign the function your jacks for different input, output or disabled - e g, turn your Mic jack into an extra Headphone, or why not make them both line outs and connect them to your surround receiver?

Install alsa-tools-gui

sudo apt-get update
sudo apt-get install alsa-tools-gui

Run hdajackretask Then To override one of your jacks:

  1. Select a codec
  2. Click the "Override" checkbox for that pin and select the new desired function
  3. Test out the changes with the "Apply now" button
  4. Once satisfied, click "Install Boot Override"

enter image description here


Are you disabling the Auto-Mute Mode in AlsaMixer?

amixer sset 'Auto-Mute Mode' 'Disabled'

does the same, you could add this to some startup script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.