4

I am using Ubuntu 16.04.4 LTS, Xenial with KDE. System is in German, I have Cherry Keyboard in German layout and I can't use IntelliJ keyboard shortcut.

For example, with "Comment with Block Comment" Ctrl + Shift + Slash, this combo doesn't work with German layout. I tried to change Keymap in IntelliJ as in screenshot, but nothing works

enter image description here

Any suggestions much appreciated .

  • In 18.04 and Gnome it happens as well. – Gonzalo Matheu Dec 26 '18 at 13:01
0

I had the same issue (under Ubuntu 18.04 with Gnome) and resolved it by uninstalling the english keyboard layout. I went to settings -> region & languages . There I had both, the German Layout and the English Layout as input sources. I removed the English input source.

  • This content is too less as an answer, so this answer needs to be made as a comment. – vine_user Jun 1 '18 at 23:07
0

This can happen if you use Ctrl + Shift in OS as layout change keys combination, for example.

Try using Left Ctrl + Left Shift to separate OS and Intellij key listeners. In this case more general Ctrl + Shift + Slash will work for the right side keys combination in IDE: Right Ctrl + Right Shift.

0

This seems to be an old issue in IntelliJ: Keyboard layout stop switching sometimes

The current workaround is to change Input Sources order in Settings -> Region & Language and put your desired layout first. No IntelliJ restart required.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.