6

Running this through an external DVD drive. Videos app says DVD source is required to play the file, but is not installed. Hitting play in VLC activates the disc (you can hear it start up in the drive) but nothing happens. I've installed Ubuntu Restricted Extras and libdvdread4 and libdvdcss.

I know varieties of this question have been asked before, but none of the answers I've tracked down are solving the issue.

  • I hope you have the drivers installed properly – user227495 Mar 9 '18 at 3:20
  • 1
    Well, gee, I do too, but do you have any actual suggestions? – Cruiser13 Mar 9 '18 at 3:49
  • 2
    Have you installed libdvdnav4 as well? Also, what version of Ubuntu are you using? – Terrance Mar 9 '18 at 4:13
  • Yes, libdvdnav4 did it. Thanks! – Cruiser13 Mar 9 '18 at 4:33
  • I'll write that up as a quick answer. – Terrance Mar 9 '18 at 4:39
4

When it comes to playing DVDs in Ubuntu, the libdvd applications needed to play DVDs are not installed by default. To install them run the following:

From a terminal window:

First, enable the Universe/Multiverse repositories:

sudo add-apt-repository universe
sudo add-apt-repository multiverse
sudo apt update

Then install the missing applications:

sudo apt install libdvdcss2 libdvdread4 libdvdnav4 ubuntu-restricted-extras

You may have to install the libdvd-pkg instead:

sudo apt install libdvd-pkg

Hope this helps!

| improve this answer | |
  • 1
    ubuntu-restricted-extras was necessary in my case – cipricus Mar 15 '19 at 19:08
  • This did not permit me to watch a DVD on VLC 3.0.4 in Ubuntu 18.10. – Lexible Apr 19 '19 at 23:52
  • @Lexible I believe that for 18.10 it is just the package of libdvd-pkg to be installed for DVDs. – Terrance Apr 22 '19 at 3:12
  • @Terrance Nope. – Lexible Apr 22 '19 at 4:12
  • @Lexible Hmm, don't know what else to tell you. I just did a clean install of 18.10 here and installed the libdvd-pkg and everything worked fine. I was able to play DVDs in VLC 3.0.4. – Terrance Apr 23 '19 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.