-1

I have an issue that you guys might be able to help me fix. I have received a all new XPS 15 yesterday, and installed Ubuntu 17.10 on it.

It currently work like a charm with Wayland. I have the proprietary drivers installed and bumblebee to help me have a decent battery life!

The issue I have is that I am unable to login in a Xorg session. Wayland is nice but there is some softwares that I need that requires to run on Xorg.....

So what happens is that I change the session in GDM3 to Ubuntu On Xorg and then nothing happens. The mouse is frozen. Well, the laptop just freezes. It feels like I have nouveau installed or that is being loaded for some reasons. It is weird cause nouveau is blacklisted and I have added the following parameter to my grub: nouveau.modeset=0 which helped me boot in the live disk when I wanted to install Ubuntu yesterday.

This is my lspci output:

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation Skylake PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-H Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1c.1 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #2 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1d.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #13 (rev f1)
00:1d.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #15 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Device a171 (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
02:00.0 Network controller: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader (rev 01)
04:00.0 Non-Volatile memory controller: Toshiba America Info Systems Device 0116

Thank you guys! Don't be shy ask me for more details if it is needed!

  • Forgot to mention earlier, please don't add "Solved" to the title. Instead, you can mark an answer as "Accepted", which will essentially mark the question as "Solved" – wjandrea Mar 10 '18 at 6:47
0

I found the solution to my problem

I used theses resources to fix my issues:

First of all, my problem was related to bumblebee, which would make my computer freeze when I wanted to switch for Xorg. Uninstalling it made it work.

I still had a few issues with my laptop so I went on and looked the rest of the doc I had, so I added the following from https://gist.github.com/whizzzkid/37c0d365f1c7aa555885d102ec61c048

sudo nano /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT='pcie_port_pm=off acpi_backlight=none acpi_osi=Linux acpi_osi=! acpi_osi="Windows 2009"'
sudo update-grub2

That fixed an issue, I had when I rebooted my machine. My laptop would freeze on boot!

That didn't fix my problem with Bumblebee though!

So I went on the ArchWiki to see what could be achieved and noticed that bumblebee seemed to be used by other user.

So I found that gist: https://gist.github.com/parasquid/5cbfb9a8f4159b546ab8b2ef2328d942, from which I saw the following code:

configure required kernel parameter (https://github.com/Bumblebee-Project/bbswitch/issues/148)

sudo nano /etc/default/grub
change this parameter to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_rev_override=1"
sudo update-grub2

I rebooted and everything worked!

I hope it will helps other people having the same problem I had!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.