2

Network configuration:

'Wireless is disabled by hardware switch' 'Enable wireless' is disabled and I can not enable it

When I press Super+F2 - no results. Wifi is not fires on a pad.

  • 1
    Well... stating the obvious, is your wireless disabled by the hardware switch? Press the wireless button on your computer and find out. – William Feb 4 '12 at 12:34
1

Had the same experience. I disabled wireless (in Ubuntu's network manager) and then was unable to re-enable it. Fn+F2 doesn't do anything inside Ubuntu; I needed to reboot Windows to re-enable wireless, where Fn+F2 behaved as expected.

2

I had the same problem, this fixed it for me:

sudo modprobe iwlagn power_level=5
sudo modprobe btusb reset=1
sudo rfkill unblock all

Then disable and re-enable wifi with fn+f2. After that, fn+f2 works, bluetooth can be disabled without disabling wifi, and wifi can be re-enabled after it is disabled.

0

I had the same problem with the Dell XPS 13 Developer Edition (i.e. Ubuntu pre-installed). A workaround was to reboot, but it only helped when I first pressed Fn+F2 again (so that it should work) and then re-booted.

0

The Intel wireless driver module appears to have been renamed. Try replacing iwlagn with iwlwifi like so:

sudo modprobe iwlagn power_level=5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.