2

I downloaded perf program for Ubuntu using this command:

sudo apt-get install linux-tools-common linux-tools-generic

But when I try perf top it gives me this

WARNING: perf not found for kernel 4.9.78-xxxx

You may need to install the following packages for this specific kernel:
 linux-tools-4.9.78-xxxx-std-ipv6-64
 linux-cloud-tools-4.9.78-xxxx-std-ipv6-64

You may also want to install one of the following packages to keep up to date:
 linux-tools-std-ipv6-64
 linux-cloud-tools-std-ipv6-64

I tried running

sudo apt-get install linux-tools-4.9.78-xxxx-std-ipv6-64

But it doesn't work.

I tried

sudo apt install linux-tools-std-ipv6-64 linux-cloud-tools-std-ipv6-64

But I got

E: Unable to locate package linux-tools-std-ipv6-64
E: Unable to locate package linux-cloud-tools-std-ipv6-64
4
  • Try apt install linux-tools-std-ipv6-64 linux-cloud-tools-std-ipv6-64, this is version independent and will work for later kernel updates. Mar 8 '18 at 7:52
  • I tried it and got this Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package linux-tools-std-ipv6-64 E: Unable to locate package linux-cloud-tools-std-ipv6-64
    – edward
    Mar 9 '18 at 15:09
  • Please edit the output of lsb_release -a into your post. Thank you for helping us help you! `
    – Elder Geek
    Mar 14 '18 at 23:15
  • Voting to close as unclear as failing to edit your post to respond to requests for additional information is a poor strategy for obtaining quality answers. Not all packages are available for all releases of Ubuntu.
    – Elder Geek
    Mar 19 '18 at 16:22
1

I'm unfamiliar with your particular kernel version which tells me that are either trying to install software for an unsupported release and should likely upgrade or your running a custom kernel. All I can tell you with any certainty is that perf is in the tools directory of the kernel source tree and that you can obtain the sources for your major version of the kernel here.

2
  • I tried locally on a 4.4 kernel and perf worked perfectly. But on 4.9.78 this is still an issue. I cannot run more tests on the real machine which has the issue as I could be jeopardizing alot of valuable files which I don't want to loose. But perhaps I can download that kernel on my local machine and give it a try, or if someone from this community has a solution / possibility to do the same, that would be essential. Thank you though for the comment
    – edward
    Mar 15 '18 at 16:16
  • @edward If you aren't backing up you are already jeopardizing valuable files. If you have a tested and true backup and restore procedure, you can try whatever you like. Feel free to drop me a comment when you have accomplished this and I may be able to add some clarity to my answer.
    – Elder Geek
    Mar 15 '18 at 16:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.