2

I am not able to boot into ubuntu (turning the PC on goes straight into Win10).

I am working on a ThinkStation P410.

When I enter the bios boot options (F12), I do see "UEFI: Windows boot manager" but not ubuntu-like entries.

SecureBoot and quick boot are both disabled; boot mode says "uefi only".

I tried boot-repair and it did not work, also updated bootmgr in Win10 with path \EFI\Ubuntu\shimx64.efi without improvement.

I am posting from ubuntu liveCD, though I need to modify the grub option including acpi=off, otherwise it stalls. My ubuntu is installed in separate partitions for root (/) and home. I also created an empty 1GB partition for bootloader(s) only, at the beginning of the disk, but I haven't used it yet as I need a bit more understanding of what's going on.

I have backup of my data, and I am keen to try things to fix this. I actually re-installed ubuntu, and it did not work either. Since I do have a limited knowledge/understanding of Linux, I would really appreciate if someone can illustrate me a bit of boot/existence of two OSs on a drive, one of them being ubuntu. For example, something I do not get yet is: grub can boot (any?) linux & Win OS but the windows one cannot? If so, could I get rid of the Win one and deal with a single bootloader installed onto the drive, perhaps within its own partition?

I would also appreciate if someone can illustrate me how to "clean" the bootloader(s) from unnecessary stuff.

Also, this problem came up when ubuntu wanted to update and then requested me to reboot, which I generally don't. So the problem might have been there for a while already or not, I just don't know. That's also why I would like to get a bit of better understanding of the entire boot/grub process and setup.

Thanks in advance folks. Cheers

edit: additional info

sudo fdisk -l /dev/nvme0n1

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1   2099200    3020799    921600   450M Microsoft basic data
/dev/nvme0n1p2   3020800    3225599    204800   100M EFI System
/dev/nvme0n1p3   3225600  385814527 382588928 182.4G Microsoft basic data
/dev/nvme0n1p4 385814528  804902911 419088384 199.9G Windows recovery environmen
/dev/nvme0n1p5 804902912 1000214527 195311616  93.1G Windows recovery environmen
/dev/nvme0n1p6      2048    2099199   2097152     1G BIOS boot

Partition table entries are not in disk order.

p4/5 are the linux partitions that I am trying to save.

  • If booting with UEFI (which you should if Windows is UEFI) then you do not need a bios_grub partition. That is only for BIOS boot on gpt partitioned drives. It also is 1 or 2MB as only grub's core.img will be in it. Grub only boots working Windows and systems installed in the same boot mode as Ubuntu. help.ubuntu.com/community/UEFI Is RAID off? What video card? If nVidia are you using nomodeset? Can you select ubuntu entry from UEFI one time boot entry? Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info – oldfred Mar 8 '18 at 4:33
  • Thanks @oldfred RAID should be off (ubuntu@ubuntu:~$ sudo mdadm --assemble /dev/nvme0n1p4 mdadm: device /dev/nvme0n1p4 exists but is not an md array.) Yes it's nvidia video card. From liveCD I mounted /dev/nvme0n1p5 and added nomodeset to /etc/default/grub then update-grub. It updated, but rebooting still results in going straight to Win10. pastebin from boot-info link – asdf1234 Mar 8 '18 at 9:02
  • No it is RAID or Intel SRT settings in UEFI that cause issues. Drives need to be set for AHCI, but if changing you must add AHCI driver to Windows first. Many with Dell needed both Dell's UEFI updated but also the NVMe drive's firmware updated. Do you have latest updates for your system? – oldfred Mar 8 '18 at 13:48
  • @oldfred I just run system update which included chipset driver, RST, flash bios, AMT and LAN drivers. From BIOS, I could see that AHCI was already enable, though I did follow the procedure: set safeboot, enable ahci, unset safeboot. Should I run boot-repair again? or where to now? Thanks a lot for your support! – asdf1234 Mar 9 '18 at 2:15
  • okay, I finally managed to get it back! While waiting for further help, I did (in order): run boot-repair and reboot, which still went to Win10 directly. Restarted once again (actually just to check that the earlier update did not change the BIOS settings) and noticed that OS optimised defaults was enabled (indicating Win10 as reference OS), therefore I disabled it. Restarted and F12 for boot options, and my dear ubuntu was there, standing tall amongst all the rest. Thanks @oldfred for the support and motivation in looking for a solution to this issue. Cheers – asdf1234 Mar 9 '18 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.