1

For several days since install I had my Broacom Wi-Fi working flawlessly on both interfaces, 2.4 GHz and 5 GHz. To install it I had to install 2 packages firmware-b43-installer and b43-fwcutter. However following a prolonged DNS server failure, the 5 GHz interface is shown permanently as Out of Range and unusable.

enter image description here

Although Mac OS and Windows still have no problem using it, right on the same hardware in multi-boot... So it's definitely a configuration failure in Ubuntu.

I did a full removal, purging the 2 packages and re-installing them to no avail. For instance right after the original install I could see some brcmwl hardware while checking for hard blocked:

$ rfkill list all
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: brcmwl-0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
$ 

Right after the trouble appeared and as well after full re-install of the 2 packages I have only:

$ rfkill list all
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
$ 

As brcmwl-0 disappeared completely.

As well the following command list only the 2.4 GHz interface:

$ iwconfig
wlp5s0b1  IEEE 802.11  ESSID:"Linksys37528"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: B4:75:0E:F8:C4:36   
          Bit Rate=36 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:13  Invalid misc:99   Missed beacon:0
$ 

It looks like it's disabled somewhere. But how to fully enable all Wi-Fi interfaces in Ubuntu ? Something is garbled somewhere.

Running theWireless Info Script suggested by this answer from Ask Ubuntu, and posted online here, just list the 14 2.4 GHz channel frequencies on wlp5s0b1 interface. However no wlp5s0b0 or wlp5s0b2 is found, and this is the real problem.

One excerpt shows troubling info. as well regarding the 5GHz interface:

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Linksys37528 1]] (600 root)
[connection] id=Linksys37528 1 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlp5s0b1' [IF6]> | mac-address-blacklist= | ssid=Linksys37528
[ipv4] method=manual
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Linksys37528]] (600 root)
[connection] id=Linksys37528 | type=wifi | permissions=
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=Linksys37528
[ipv4] method=manual
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Linksys37528_5GHz 1]] (600 root)
[connection] id=Linksys37528_5GHz 1 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlp5s0b1' [IF6]> | mac-address-blacklist= | ssid=Linksys37528_5GHz
[ipv4] method=manual
[ipv6] method=auto

[[/etc/NetworkManager/system-connections/Linksys37528_5GHz]] (600 root)
[connection] id=Linksys37528_5GHz | type=wifi | permissions=
[wifi] mac-address=<MAC address> | mac-address-blacklist= | ssid=Linksys37528_5GHz
[ipv4] method=auto
[ipv6] method=auto

As the [ipv4] method=auto is dead false. It is like on the 2.4 GHz set to manual. I did set it another time to manual , but still the profile won't budge to auto here. Although when checking in System Settings it is definitely set as manual addressing.

Where can I find the appropriate support in Ubuntu to fix this troubling network adapter configuration ? There seems to be close to none support about it.

6
  • "However no wlp5s0b0 or wlp5s0b2 is found, and this is the real problem." It doesn't work that way. Either your wireless interface wlp5s0b1 does 2.4 gHz and 5 gHz or it does not. I'm studying. More later.
    – chili555
    Mar 7, 2018 at 23:09
  • What is the result of: sudo dpkg -s bcmwl-kernel-source | grep Status ?
    – chili555
    Mar 7, 2018 at 23:15
  • As I said before I didn't install this package as it did not support my Broadcom BCM94331CD. So the result is package is not installed and no information is available.
    – Antonio
    Mar 7, 2018 at 23:22
  • So, you already tried it and it didn't work? I suspect you had it in place at some point because of this: "brcmwl-0: Wireless LAN" in rfkill. There are at least four things we could try, all experimentally, and bcmwl-kernel-source is the first. Shall I propose an answer here or is this easier to do in chat?
    – chili555
    Mar 7, 2018 at 23:32
  • May be it's easier in chat. May be you didn't get it right. The package bcmwl-kernel-source won't work for my adapter. $ lspci -nn -d 14e4: 05:00.0 Network controller [0280]: Broadcom Limited BCM4331 802.11a/b/g/n [14e4:4331] (rev 02) I suggest you read askubuntu.com/questions/55868/… about it. It was working on the initial install and I kept the result in a text file. That is what I've posted here. But after the incident, it never showed up.
    – Antonio
    Mar 7, 2018 at 23:43

1 Answer 1

1

Well, I ended up re-installing package bcmwl-kernel-source as chili555 told me. Thanks for his suggestion.

[Side NOTE]: bcmwl-kernel-source was first installed, because I used another network adapter which was working well with it on both 2.4 GHz and 5 GHz. Then when I switched to a new network adapter I did install package firmware-b43-installer as it was required by the documentation available. Later I did uninstall bcmwl-kernel-source to avoid connection droppings.

The reason why is that installing the package bcmwl-kernel-source will allow Ubuntu to see the 5 GHz Wi-Fi Interface.

The trouble is that with both packages bcmwl-kernel-source and firmware-b43-installer installed, the Wi-Fi connection is dropped randomly (several times per hour at times). There might be some concurrent activity behind, a race condition between the 2 ?

It should be noted that from this reference answer, only firmware-b43-installer is required. as the PCI id is:

$ lspci -nn -d 14e4:
05:00.0 Network controller [0280]: Broadcom Limited BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)
$ 

Then in the BROADCOM WIRELESS TABLE (Updated Aug 18, 2017), I found this entry:

14e4:4331           firmware-b43-installer            firmware-b43-installer

Giving the package to install in Xenial 16.04 LTS and 17.10+.

Uninstalling bcmwl-kernel-source will stop the connection drops, however, from my experience, if there is a problem on the connection like a DNS Server down, you can loose the 5 GHz interface altogether as shown in the question itself.

It's a shame that we are not getting a fully working driver solution from Broadcom. This network adapter works flawlessly on 2.4 GHz and 5 GHz in Windows and Mac OS X. It looks like the working package firmware-b43-installer is old enough not to support the 5 GHz interface ?

Another answer has already suggested the removal of package bcmwl-kernel-source to avoid the connection dropping randomly. However, at least one user found this solution not functional as well.

In the mean time I wrote a quick bash script named check-for-wi-fi-up-and-runnig to restore the Wi-Fi connection as soon as it's disconnected:

#!/bin/bash
#

# Check if Wi-Fi is disabled e.g. 'out of range'
# If so quickly re-enable Wi-Fi
# Due to a problem with Broadcom proprietary driver in package firmware-b43-installer

# Script is part of Start-Up programs
# Stored in /usr/local/bin/
# Infinite loop checking every second if Wi-Fi is up and running

while true; do
  # https://askubuntu.com/questions/27954/how-can-i-check-internet-connectivity-in-a-console
  if [[ $(nmcli -f STATE -t g) != 'connected' ]]; then
    # Disable and Re-Enable Wi-Fi as the Wi-Fi is now 'out of range' (disconnected)
    nmcli radio wifi off
    sleep 3
    nmcli radio wifi on
    sleep 120
  fi
  sleep 1
done

May be I can throttled down sleep 3 to sleep 1, pending further testing.

So basically, right now it is a trade off between no connection dropping, but having to re-install a driver package at times or an unstable connection with several drops per hour at times ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.