1

I took an Acer C720 Chromebook and converted it to Ubuntu about 4 years ago. Runs great. It's been on 17.10 for awhile now no problems. On Sunday it ran fine. On Tuesday it can no longer connect to WiFi and I'm at a loss as to why. It's connected to our home SSID for years automatically. Now just tries and tries and fails. I can see every SSID in the neighborhood. Things that I have tried that have not worked:

-Rebooting
-Restart router
-Connecting to the Hot Spot on my phone
-Disabling IPv6
-Restarted Network Manager
-Verified that NetworkManager.conf contained the line [device] wifi.scan-rand-mac-address=no

A lot of what I've read for fixes refers to older versions of Ubuntu or after an update to newer version. This problem just started out of nowhere. Worked yesterday not today.

Any suggestions?

Thanks.

Edit. Added 3/9/18
I tried this line to restart Network Manager but it didn't solve the problem either. sudo systemctl restart NetworkManager.service

0

I scoured the internet more and found someone who had a similar problem with an older version of Mint, I think. They discovered the clock was set wrong. I checked mine and the date was wrong. Set to 2108 instead of 2018. I turned off automatic date and time and set to the correct date and time and was immediately able to connect to WiFi.

So if you have this problem, check your computer's date and time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.