0

I am trying to install Xenomai along with the Linux kernel version 4.4.43 in my PC. It is currently running Ubuntu 16.04 LTS. I am new to the whole Linux enviroment and from what I read online doing sudo apt-get update seemed like a good thing to do first. But I keep getting the same error saying Failed to fetch .......... 500 Operation not permitted I really have no idea what I am doing wrong.

In addition to this, I need to install OpenSSL for Xenomai. But sudo apt-get install libssl-dev tells me that it could not find the package.

I have tried to change the sources.list to use old source, but there was no change. The other software page has all options selected as well.

I have attached both images below in order. Please advice as to what I should do next.

apt-get

Unable to find package

EDIT: I have tried multiple different servers, including archive servers, but there is not difference in the output. What could be something on my end that is going wrong?

  • It may have been just a temporary problem with the server in.archive.ubuntu.com, judging from the fact that it can't find a Release File that should obviously be there. – Jos Mar 7 '18 at 12:32
  • Are you behind a firewall that requires a http-proxy? – Simon Sudler Mar 7 '18 at 13:47
  • @Jos I tried using the main server option as well, but saw no change. Should I just keep trying different servers? – Michael Thomas Mar 8 '18 at 3:40
  • @SimonSudler No. I am doing from my office and I just confirmed that there is not http-proxy requirement. – Michael Thomas Mar 8 '18 at 3:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.