0

I recently bought a Wireless USB Adapter TP-LINK TL-WN722N v3 (https://wikidevi.com/wiki/TP-LINK_TL-WN722N). At first, it seems to work but I've noticed that there were, in fact, some problems with drivers after all. So I decided to install one, in following way:

sudo add-apt-repository ppa:hanipouspilot/rtlwifi
sudo apt-get update
sudo apt-get install rtlwifi-new-dkms

When that didn't work I followed this guide:

git clone git://github.com/lwfinger/rtl8188eu
cd rtl8188eu
make
sudo make install
sudo cp -v ~/RTL8188EU/rtl8188eu/rtl8188eufw.bin /lib/firmware/rtlwifi/
sudo depmod -a
sudo update-initramfs -u
sudo modprobe 8188eu

But it gave me 'modprobe 8188eu - Exec' format error on the last command. I've also tried using dkms, but that does not seem to work either.

sudo apt-get install git dkms
git clone https://github.com/lwfinger/rtl8188eu.git
sudo dkms add ./rtl8188eu
sudo dkms install 8188eu/1.0

I'm running: Linux version 4.4.0-116-generic (buildd@lgw01-amd64-021) (gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.9) ) #140-Ubuntu SMP

Right now the device is not recognised in any way after connecting it to USB port. How can I make it running?

0

I have the official tplink page, but I haven't tried it. The driver source can be downloaded on driver folder.

A pdf installation instruction can be found on this link.

please let me know

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.