1

We've just installed an Ubuntu 17.10 server, and during the installation, it was assigned the IP address 192.168.50.84.

We've now reserved the IP address 192.168.50.107 on the DHCP server.

The netplan configuration was a surprise and, in my opinion, /etc/network/interfaces made a lot more sense to do.

Every time the server reboots, it sets the IP address to 192.168.50.84, and it doesn't seem to ask the DHCP for an IP address.

If we execute:

sudo dhclient -r; sudo dhclient

The server gets the intended IP address (192.168.50.107) from the DHCP.

So, what is wrong with netplan? Why doesn't it ask for the IP address on boot or a network restart? On every boot we get this line in the logs: Mar 6 18:48:08 blues-web-proxy systemd-networkd[723]: eth0: DHCPv4 address 192.168.50.84/24 via 192.168.50.140

Thanks for the replies.

We didn't do any configuration, the installation process only asked if it needed to use a proxy server or not - replied no.

/etc/netplan/01-netcfg.yaml

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    eth0:
      dhcp4: yes

/etc/network/interfaces

# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)
# Generated by debian-installer.


# The loopback interface
auto lo
iface lo inet loopback

/etc/hosts

127.0.0.1       localhost
127.0.1.1       blues-web-proxy.bluescreen.local        blues-web-proxy

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
  • 1
    How did you configure netplan? Are you able to include your netplan configuration here so we can see what you are working with? – Thomas Ward Mar 6 '18 at 19:08
  • Please edit your question to add the result of the terminal command: cat /etc/netplan/* Welcome to Ask Ubuntu. – chili555 Mar 6 '18 at 22:46
  • What DHCP server do you use? How was the reservation configured? Networkd uses DUID by default as an unique identifier for DHCP and this fails on some configurations. – Mathieu Trudel-Lapierre Mar 9 '18 at 16:34
  • It is a Windows Domain, we are using Microsoft DHCP server – Carlos Oliveira Mar 19 '18 at 18:39
  • Sounds like this is the same as askubuntu.com/questions/987673/… then – Mathieu Trudel-Lapierre Mar 21 '18 at 17:08
-2

Its possible netplan left some stray settings depending on how you configured it. Check the usual suspects for "static ip" settings such as /etc/network/interfaces, /etc/hostname, and /etc/hosts.

  • 2
    This would be better as a comment, as it doesn't provide an answer, just debugging information. – dpb Mar 13 '18 at 23:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.