3

Ctrl+Arrows works correctly to jump between words, however when I use Ctrl+Shift+Arrows to select by words, nothing happens.

Anybody knows how to make it work? (I'm using Ubuntu 16.04)


Output of cat /etc/default/keyboard:

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

Output of gsettings list-recursively | grep -i ctrl:

org.gnome.settings-daemon.plugins.media-keys screenshot-clip '<Ctrl>Print'
org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '<Ctrl><Alt>Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip '<Ctrl><Shift>Print'
org.gnome.settings-daemon.plugins.media-keys screencast '<Ctrl><Shift><Alt>R'
org.gnome.settings-daemon.plugins.media-keys screenshot-clip '<Ctrl>Print'
org.gnome.settings-daemon.plugins.media-keys window-screenshot-clip '<Ctrl><Alt>Print'
org.gnome.settings-daemon.plugins.media-keys area-screenshot-clip '<Ctrl><Shift>Print'
org.gnome.settings-daemon.plugins.media-keys screencast '<Ctrl><Shift><Alt>R'
org.onboard.lockdown disable-keys [['CTRL', 'LALT', 'F[0-9]+']]
org.gnome.Terminal.Legacy.Keybindings zoom-out '<Ctrl>minus'
org.gnome.Terminal.Legacy.Keybindings move-tab-left '<Ctrl><Shift>Page_Up'
org.gnome.Terminal.Legacy.Keybindings new-window '<Ctrl><Shift>n'
org.gnome.Terminal.Legacy.Keybindings copy '<Ctrl><Shift>c'
org.gnome.Terminal.Legacy.Keybindings zoom-normal '<Ctrl>0'
org.gnome.Terminal.Legacy.Keybindings zoom-in '<Ctrl>plus'
org.gnome.Terminal.Legacy.Keybindings move-tab-right '<Ctrl><Shift>Page_Down'
org.gnome.Terminal.Legacy.Keybindings close-window '<Ctrl><Shift>q'
org.gnome.Terminal.Legacy.Keybindings new-tab '<Ctrl><Shift>t'
org.gnome.Terminal.Legacy.Keybindings paste '<Ctrl><Shift>v'
org.gnome.Terminal.Legacy.Keybindings close-tab '<Ctrl><Shift>w'
org.onboard.lockdown disable-keys [['CTRL', 'LALT', 'F[0-9]+']]

dconf dump / | grep -i ctrl produces empty output

  • Oh, Dima. If you switch keyboard layout with <Ctrl+Shift> I'm completely with you. It is old bug 1683383 (really in Xorg). You can try to fix it by switching to Ubuntu MATE 16.04 LTS. I did so and I can select text with <Ctrl+Shift+Arrows>. – N0rbert Mar 6 '18 at 21:08
  • @N0rbert, no I use <Alt>+<Shift> to switch keyboard layout – Dima L. Mar 7 '18 at 17:21
  • Very strange. Which session/desktop (GNOME, Unity, MATE, KDE) do you use? – N0rbert Mar 7 '18 at 17:41
  • I have default Ubuntu installation with Unity – Dima L. Mar 8 '18 at 6:06
  • 1
    You can try Guest session for sure. – N0rbert Mar 9 '18 at 17:04
3

As @N0rbert suggested, I checked Guest session and found out that Ctrl+Shift+Arrows shortcut keys work correctly there, which means it's a matter of settings in my account.

I started to backup and remove "." folders in my account and at some point I did something wrong and my Unity settings were completely reset and Ctrl+Shift+Arrows started to work correctly.

To my regret I didn't correctly backup my wrong settings, so at this point I can't know where exactly these settings are saved, but I'm sure it's related to some Unity settings...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.