3

I recently installed the latest version of the KDE Plasma desktop (5.12) on my system, Ubuntu 17.10. I generally like the layout and appearance, but some fonts are pixelated in certain applications. I have tried to log back into the Unity environment, and there is no problems there.

I have searched forums for similar issues, and suggestions seem to be that the fonts are not made for high resolution. The weird part is that some fonts are pixelated, and some not, even when the same fonts are used, so I don't understand what the issue may be.

Examples of this are in TexStudio, where the selected line appears smooth, while the rest looks fuzzy, PDF output is also fuzzy.

in TexStudio, where the selected line appears smooth, while the rest looks fuzzy

The same problem is found in Discover package manager

in Discover package manager

Any ideas what causes this problem?

[EDIT:] On request I have checked my version of Plasma desktop. This is what I can find:

$ apt-cache policy plasma-desktop
plasma-desktop:
  Installert: 4:5.12.3-0ubuntu1~ubuntu17.10~ppa1
  Kandidat:   4:5.12.3-0ubuntu1~ubuntu17.10~ppa1
  Versjonstabell:
 *** 4:5.12.3-0ubuntu1~ubuntu17.10~ppa1 500
        500 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu artful/main amd64 Packages
        100 /var/lib/dpkg/status
     4:5.10.5-0ubuntu1 500
        500 http://no.archive.ubuntu.com/ubuntu artful/universe amd64 Packages
$ which plasmashell
/usr/bin/plasmashell
$ plasmashell --version
plasmashell 5.12.3

KDE was installed according to something like this.

  • How and from where did you install Plasma? – David Foerster Mar 7 '18 at 10:59
  • I installed via terminal, using the following command: sudo apt-get install kubuntu-desktop. The repositories were prior to install, but I did not add any new ones. – Pål Bjartan Mar 8 '18 at 11:47
  • How did get Plasma v5.12 on (K)Ubuntu Artful Aardvark then? The official repositories only contain v5.10.5? Are you sure you're not on Ubuntu Bionic Beaver? Could you please edit your question to include the output of apt-cache policy plasma-desktop, which plasmashell and plasmashell --version? Thanks. – David Foerster Mar 8 '18 at 11:57
0

So, I searhed some more, and I found a possible cause and workaround of the problem:

In the troubleshooting section of the ArchLinux' wiki on font configuration it states that

"96 DPI is not a standard. You should use your monitor's actual DPI to get proper font rendering, especially when using subpixel rendering.(...) If fonts are still unexpectedly large or small, poorly proportioned or simply rendering poorly, fontconfig may be using the incorrect DPI."

and links to the Display size and DPI section in the wiki's Xorg entry where it further states that

"Having the correct DPI is especially necessary where fine detail is required (like font rendering). Previously, manufacturers tried to create a standard for 96 DPI (a 10.3" diagonal monitor would be 800x600, a 13.2" monitor 1024x768). These days, screen DPIs vary and may not be equal horizontally and vertically."

It got me thinking about whether my screen's DPI were detected incorrectly, so I checked in KDE's display manager. In the displays menu there is a "Scale display" option. This made me recall that I did fumble with that right after install of KDE, and then remembered something I read about KDE handling fractional scaling poorly. I had like, I thought, scaled the display to 1.2x. Rescaling it to 1x makes fuzzy fonts look fine. The ArchLinux wiki Xorg entry further states

"While you can set any dpi you like and applications using Qt and GTK will scale accordingly, it's recommended to set it to 96, 120 (25% higher), 144 (50% higher), 168 (75% higher), 192 (100% higher) etc., (...)"

I have so far tried forcing 1.5 scale, which works fine.

PS: This is of course more of a workaround than addressing the issue, but at least it works. It still doesn't answer why fonts in some texts where affected while others not. (E.g. the fuzzy fonts in TexStudio, while the highlighted line is clear.)

[EDIT] I fumbled around some more. Seemingly it is the scaling in the displays menu that's causing the problem. Using 1x scaling in Diaplay and forcing font sizes 120, 144 in the fonts menu, seems to work without problems. Setting fonts to default but scaling displays on the other hand creates fuzzy text like seen in the pictures I posted.

| improve this answer | |
  • Just a quick note that I had the exact same issue with Kubuntu 18.04.4, I use a 4K screen with NVIDIA GPU. I had the scaling option set to 1.5 and font DPI to 144 and things were blurry. I also fixed it by setting the scale to 1 but keeping the font DPI to 144. The desktop elements look slightly larger, but not too bad. – Maghoumi Feb 6 at 17:47
0

For me it had nothing to do with the font DPI. I have ran into this problem several times on Nvidia graphics cards running their drivers. Inside KDE:Plasma settings, a feature exists to change the "Compositor" and this compositor can be set to OpenGL3, OpenGL2, or XRender. For me XRender is what made my system usable and prevented the fonts from getting blurry.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.