1

I am getting the following messages in my /var/log/boot.log:

lvmetad is not active yet, using direct activation during sysinit
"disk/by-uuid/db9c53d1-9f64-4bb7-970c-9fce38b499d4": Invalid path for Logical Volume.

The UUID is my swap partition, which is also used for hibernation. By trying out different config options I was able to trace the root of the message to my grub configuration.

My /etc/default/grub looks like the following:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX="resume=UUID=db9c53d1-9f64-4bb7-970c-9fce38b499d4   other-option=value"

For reference my /etc/fstab:

# <file system>                           <mount point>   <type>  <options>         <dump>  <pass>
# sda4 
UUID=38a2c53b-2a10-4653-8869-b819c1b0c3be /               ext4    errors=remount-ro 0       1
# sda5
UUID=51cd4543-09c0-4eb6-959a-692991c4429e /home           ext4    defaults          0       2
# sda2
UUID=db9c53d1-9f64-4bb7-970c-9fce38b499d4 none            swap    sw                0       0
# sda1
UUID=36A8-4C49                            /boot/efi       vfat    umask=0077        0       1

I already tried lots of different settings to fix this error message, including uninstalling LVM2, since I do not use any logical volumes.

Does anybody know how to get rid of the error?

1

Old answer:

Just found the solution by chance browsing some more blogs.
See the following comment by Brandon Beck: http://chriseiffel.com/uncategorized/step-by-step-how-to-get-hibernate-working-for-linux-ubuntu-11-04-mint-11/#comment-116

I had to change /etc/default/grub to use the PARTUUID of the swap partition instead of UUID like this:

"resume=PARTUUID=..."

You can get the PARTUUID of the swap partition with blkid.
Afterwards, run sudo update-grub.

Revised answer:

After changing the grub entry to PARTUUID hibernation did not work anymore. Maybe /etc/initramfs-tools/conf.d/resume needs to be adapted accordingly.

However, I just reformatted my swap partition, which was previously created by Clonezilla, and updated all config files with the new UUID. I also switched back /etc/default/grub to use UUID for "resume" and entered the new one.
Now, hibernation works again and the error message in boot.log also disappeared. Problem seems to be finally resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.