0

I have a fresh Ubuntu 17.10 installation on my desktop computer and its wifi is much slower than normal and sometimes just cuts out.

I've tried connecting to ethernet to download updates and it seemed to improve the situation a little, but the wifi was still uselessly slow.

I also tried a suggestion using modprobe to do something to the rt2800pci module, but I don't know what the command really does and I can't find the original article suggesting it.

The best result I had was editing the /etc/resolv.conf file as suggested here: Extremely slow connection after 17.04 update. It worked for a little while, but after a couple restarts from installing software the wifi went back to dead slow connection. Meanwhile all other devices on the network are fast like normal.

Wireless info script output.

  • I'm not really sure if I'm being specific enough in my question, but it's the best I have for now unless someone has a suggestion. I just usually don't get that great of help on here. lIt's usually something like "its in the latest release so just update" but if it were that simple, I'd be able to fix this problem using the update I did right after installing. – Paul Ronquillo Mar 6 '18 at 6:42
0

I assume this is your router or access point:

Cell 01 - Address: <MAC '582A0A' [AC1]>
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=54/70  Signal level=-56 dBm  
                    Encryption key:on
                    ESSID:"582A0A"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=000006a984e16b42
                    Extra: Last beacon: 4ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PS

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

I have worked on more than one RT2800 case where connectivity was improved when the router was set to use 802.11A, B and G only; in other words, disabling N speeds. I suggest that you experiment with both modes.

Reboot the computer and the router and let us hear if there is any improvement.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.