1

Okay, so some background info: We have a linux server in our data closet which we all connect to over the network to access files. File sharing was set up with SAMBA. I also set up SSH with PuTTY to remote into the terminal. And I also have VNC Viewer to remotely connect to the Ubuntu Desktop. Also had Ajenti set up for it.

Previously all 4 ways of connecting to the server worked.

Today, someone reset the power in the data closet because something wasn't working for them (not really sure what). This reset the power to everything including router and the server, etc...

I don't think rebooting the server alone should have affected any of the above services... considering I'm certain I rebooted the server a couple times while setting all that up.

This is where things get weird... So the connection to the server is super faulty right now but not totally gone... When I try to connect to the server any of the 4 ways I mentioned(SAMBA fileshare, PuTTY, VNC & Ajenti), I'll get some kind of error. However, randomly, for short increments of time, the connection will be restored and working exactly how it's supposed to be on all or some.. it truly is random, sometimes i can connect to the fileshare and VNC remote session for a minute but can't SSH. I'll also get different errors trying to use the same program, seems to be nonsensical... Any time I look up a fix for each service individually, the fixes are too closely related to the software rather than the network connection to it.

I can Ping my Ubuntu server just fine..

My Ubuntu server shows up under NETWORK in windows explorer although I can't access it.. which probably gave me the best piece of information I'll need to solve this:

Windows Network Diagnosis ERROR

'The device or resource is not set up to accept connections on port "the file and printer sharing (SMB)"'

I've researched the error but I couldn't find a viable solution for my setup. I'm lost, i feel like this should be a super simple solution but I've been at it for hours now. I've looked at the services above, they're all running (maybe another service turned off after reboot that is essential?). I've restarted each of them.. I tried rebooting the server again... checked my smbd.conf file to make sure it hadn't reverted back to defaults..

This is frustrating because everything appears to be the exact way it's supposed to be and it should work. ...and it DOES work... for like a minute.. i don't know. any help would be appreciated.

EDIT
Starting to think it has to be a Network Card issue or something. Based on the random nature of my issue. On my Ubuntu Machine, I ran a couple internet speed tests, they'd either not complete due to an "issue with the network" or complete really sluggishly although it would reveal the correct download and upload speeds which are fast..

  • Does your server get it's IP address from the router via DHCP ? Could something else on the network have the same IP ? – hatterman Mar 6 '18 at 13:35
  • Yes I believe the server obtained the IP from my router. I'm doubtful about anything having the same IP address. The office I'm in in small, I haven't noticed any new tech come in that needs an IP address. and the connection was fine prior to the power being switched off. – bmacx7 Mar 6 '18 at 13:56
  • It might be worth doing a quick and easy test. Ping your router. Then disconnect the router LAN cable and ping it again. I'm sure your right, but I have seen IP addresses be assigned incorrectly a few times when part of a network loses power. – hatterman Mar 6 '18 at 14:00
  • So I ran a few ping tests from my Ubuntu machine. I pinged my router 3 times... First I got 50% packet loss, 0% packet loss and then 100% packet loss – bmacx7 Mar 6 '18 at 14:28
  • OK. So now ping your server. Then disconnect its LAN cable and ping the server again. – hatterman Mar 6 '18 at 15:38
0

SOLVED: IP was originally set up dynamically, which caused issues when the router was reset and i guess it gave another device the same IP. So I changed the /etc/network/interfaces file to set up a static IP address for my server. Now everything reconnects properly. thanks Mad hatterman!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.