I know that this question is already asked but I still have an issue. I am using a ssh to connect to a virtual machine via this command:

ssh -X <ServerName>

Of course we can only work with a terminal. Therefore I am trying to install a GUI. I did:

sudo apt-get ubuntu-desktop


sudo apt-get mate-desktop

So I disconnect and connect again to the VM with ssh and still with the prompt command. How could I start with the GUI.

Then I install a XRDP like my teacher told me. But I still don't have any GUI. However, when I just launch firefox it appears.

What can I do ?


  • Please edit your question to elaborate on "everything that I tried", and why you believe each attempt failed. Did you properly clean up after each failed attempt? Or is your system currently littered with dozens of broken files that interfere with subsequent attempts?
    – user535733
    Mar 5, 2018 at 20:16

2 Answers 2


attempt running the command:


to initialize the xorg session.

You have to tell the server to start a gui session.


I fixed it like this:

echo “xfce4-session” > ~/.xsession
# /etc/init.d/xrdp start

follow this tutorial.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.