0

I have Ubuntu 16.04 LTS version and trying to install VirtualBox.

I installed VirtualBox from command line many times and also today (05.03.2018). The installed version is 5.0.

I set-up the virtual machine. When I start it, the VirtualBox shows this message "You have Auto-capture keyboard option turned on. This will cause ...." and whole system is halted (my own laptop / host computer). I am unable to do anything after this point.

I tried to download the DEB file from VirtualBox website and install it; but it is not working either. It does not open Ubuntu Software and when I click the DEB file, nothing happens.

Can anyone please let me know that I am doing wrong?

Here is the picture of the error

  • I have tried sudo apt-get update but it does not help. – Syed Kazmi Mar 5 '18 at 16:23
  • Sounds like you assigned too many things to the VM. What are the specs of the computer, and can you provide a screenshot of the VM configuration (CPUs assigned, etc.) so that we can compare what you have available and what you're assigning, to better help you with configuring the VM? – Thomas Ward Mar 5 '18 at 16:26
  • Here is my host computer: photos.app.goo.gl/K3wqfbN0qQJytJXS2 I have deleted the whole VirtualBox now but I had following specs with the VM: RAM: 10Gb CPU: 4 OS: Ubuntu Server 16.04 LTS Memory: 120Gb – Syed Kazmi Mar 5 '18 at 16:32
  • When you say "memory" you mean disk space, correct? Also, try reducing the number of CPUs to 2 - you should never, in Virtualbox, assign more CPUs than you have physical cores in the system (and the x 8 just means you have hyperthreading enabled though you only have 4 physical cores). – Thomas Ward Mar 5 '18 at 17:21
  • Thanks for the answer. Yes, I meant disk space :) I tried it with 2 CPUs and it is working fine now. Thanks a lot! – Syed Kazmi Mar 6 '18 at 13:14
0

I had an almost identical problem on both Ubuntu 14.04 and 16.04 - including the total freeze. As far as I remember, the problem was somehow related to a meltdown/spectre "fix". The solution was to follow the instructions under Debian-based Linux distributions on https://www.virtualbox.org/wiki/Linux_Downloads and eventually install virtualbox-5.2. Also see solution here: virtualbox crash on kernel 4.13.0-26.

  • I think I was the third party repositories. I followed the steps and now it is working! Thanks a lot! :) – Syed Kazmi Mar 6 '18 at 12:56
  • Just to add that the link was not working due to some reason. But I searched and found it easily! :) – Syed Kazmi Mar 6 '18 at 12:58
0

Try using gdebi. It will resolve dependiencies for .deb files. You can install it with:

sudo apt-get install gdebi-core

Then use

sudo gdebi packagename.deb

in the correct directory.

With that said, virtualbox has given me the same issue on Ubuntu, but I didn't install the .deb file, but instead went with an alternative:

sudo apt-get install qemu-kvm

I've used both hypervisors and other vm software and this product works very well and is supported by Ubuntu's Server team.

  • I'd also like to add that I'm running an i7 and 16 gb of ram, so I know it's a problem with Oracle's drivers, not lack of power. – David Kamer Mar 5 '18 at 18:20
  • 1
    Thanks for the answer. I have been using the QEMU. It really works fine for me also. But I needed the Guest Auditions to copy and paste the commands. :) – Syed Kazmi Mar 6 '18 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.