-1

I recently installed Ubuntu, and I want to add a PPA for MAXE-TV, however I get this error when I try and use the PPA:

E: The repository 'http://ppa.launchpad.net/venerix/pkg/ubuntu artful Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I also cannot download anything, and this is a pretty annoying issue.

What exactly is wrong?

I add first sudo add-apt-repository ppa:venerix/pkg It comes up a window saying that are you sure you want to install TV-MAXE and i click enter Then I write sudo apt-get update and the errors up there comes up, it just says that it's uploading the file nothing else :/

  • Please review my edits, I tried to make your question more understandable but I am not 100% certain I captured everything you were aiming for. (Also please don't use phrases like 'WTF', there's no need for obscenities here) – Thomas Ward Mar 5 '18 at 16:22
  • sudo add-apt-repository ppa:venerix/pkg when i'm adding that i can confirm that i want to download the file but when i write in the terminal sudo apt-get update this error comes up – Simon Wahlgren Mar 5 '18 at 16:43
  • FYI, if you actually had read the output from sudo add-apt-repository ppa:venerix/pkg you would have seen the "Supported Versions" line stops at 14.10, indicating you should't have added the PPA to begin with, and that the PPA is no longer updated or maintained. – Thomas Ward Mar 5 '18 at 17:38
1

I highly doubt that you can't download anything, but I can say with certainty that the issue you're getting with that PPA is because the maintainer hasn't updated the PPA since Utopic Unicorn - which is 14.10 and is long past end of life.

There are no packages in that PPA for Artful, so you cannot use that PPA for Artful. This is why you're getting the "does not have a Release file" error - there is no packages for Artful so the Release file doesn't exist.

You need to remove the PPA since you cannot use it - there is no other option to resolve this error. You can remove it with the following command in the Terminal:

sudo rm -rf /etc/apt/sources.list.d/venerix-ubuntu-pkg*.list*

Then run sudo apt-get update again.

You cannot use this repository for tv-maxe anymore. It does not work. You must remove this repository to get rid of that error about that repository.


(For 16.04 and earlier only)

However, if you absolutely need to use this software, then you can try this solution from a comment on this post on ubuntublueprint.com:

sudo add-apt-repository ppa:trebelnik-stefina/tv-maxe
sudo apt-get update
sudo apt-get install tv-maxe

Either way you need to remove the venerix PPA you installed earlier, using the above instructions I provide to do so.

  • I did what you said, but then when i try to install maxe tv it doesen't work what could be wrong, the same error comes up – Simon Wahlgren Mar 6 '18 at 14:53
  • @Simon Again, you cannot use that repository. You need to remove the repository from the system with the commands I gave you. You also cannot install MAXE-TV with that repository, because the repository does not support 17.10 – Thomas Ward Mar 6 '18 at 15:00
  • If i download a earlier version of ubuntu, will it work then? :) – Simon Wahlgren Mar 6 '18 at 15:11
  • @SimonWahlgren No. Use the instructions in my answer to remove teh venerix PPA. Then use this entire set of commands and see if that helps to install the app: sudo add-apt-repository ppa:trebelnik-stefina/tv-maxe && sudo apt-get update && sudo apt-get install tv-maxe – Thomas Ward Mar 6 '18 at 15:37
  • okay,,, thanks you're really good at ubuntu so i can use tv-maxe in 17.10? so I don't need to dowgrade or anything :) okay, so all i do is to open the terminal, copy the first thing with the delete venerix and then past these last things? :) – Simon Wahlgren Mar 6 '18 at 15:48

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.