I wanted to change my desktop environment (DE) to cinnamon because it was way faster on my test computer.

I ran the command: apt-get install cinnamon-desktop-environment


Changed the DE to Cinnamon.

Put my password in, and then it kicked me back into the greeter.

When I looked at the logs, I found this error message:

Mar  5 13:28:39 lab-linux-01 cinnamon-session[7991]: GLib-GIO-ERROR: t+0.01202s: Settings schema 'org.gnome.desktop.file-sharing' does not contain a key named 'enabled'#012aborting...
Mar  5 13:28:39 lab-linux-01 kernel: [  588.104932] traps: cinnamon-sessio[7991] trap int3 ip:7fc180cd3ad1 sp:7fffb34390a0 error:0 in libglib-2.0.so.0.5502.0[7fc180c82000+113000]

Googling around for this error message did not yield very much help.

  • Exact same issue! Commented Jul 4, 2018 at 20:21

1 Answer 1


The key were these parts of the message: GLib-GIO-ERROR and Settings schema 'org.gnome.desktop.file-sharing'

Where does GLIB store its schemas?


$ cd /user/share/glib-2.0/schemas/
$ grep file-sharing *
Binary file gschemas.compiled matches
org.gnome.desktop.file-sharing.gschema.xml:<schema path="/org/gnome/desktop/file-sharing/" id="org.gnome.desktop.file-sharing" gettext-domain="gnome-user-share">
$ dpkg -S /usr/share/glib-2.0/schemas/org.gnome.desktop.file-sharing.gschema.xml
gnome-user-share: /usr/share/glib-2.0/schemas/org.gnome.desktop.file-sharing.gschema.xml

Aha - gnome-user-share looks like the culprit!

What does gnome-user-share do?

$ apt search gnome-user-share
Sorting... Done
Full Text Search... Done
gnome-user-share/bionic,now 3.18.3-3 amd64 [installed]
  User level public file sharing via WebDAV

I do not need User level public file sharing via WebDAV, so I will remove it.

$ apt-get purge gnome-user-share

I rebooted the computer and was able to login to a nice Cinnamon desktop.

Time to go make some Cinnamon Toast. Does anyone have a good recipe for that for that? ;-)

  • 6
    This solved my problem when updating Ubuntu 16.04 to 18.04, I could log into Gnome but Cinnamon had problems until I removed gnome-user-share. Thanks for the tip!
    – Gargravarr
    Commented Apr 27, 2018 at 12:23
  • @Gargravarr if question and answer was useful, please upvote them if you can. Thanks :)
    – David
    Commented Apr 27, 2018 at 16:51
  • 1
    already did :) posted the comment so it gets found by Google
    – Gargravarr
    Commented Apr 30, 2018 at 11:32
  • 1
    @David deserves some cinnamon rolls ! This solved my problem :)
    – dooxe
    Commented May 14, 2018 at 7:39
  • 1
    Did anybody report this as a bug?
    – adhominem
    Commented Jun 6, 2018 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .