1

I have an HP computer and I installed Ubuntu. In the BIOS, I disabled Secure Boot and enabled Legacy Support. It also says that when Legacy is enabled, both UEFI and Legacy are available and UEFI has a higher priority. Is there a way to give preference to Legacy? I know that for HP it is possible to press F9 after turning on the machine and select the Hard Drive, but having to do that every time would be annoying.

  • 1
    This is more a "bios" problem than an Ubuntu o windows problem. Also I advise you 8nstall uni to with uefi enable rather than legacy – Panther Mar 5 '18 at 0:18
  • you should be able to set legacy boot priority in the "bios" boot settings – ravery Mar 5 '18 at 0:26
1

I changed the value for post hotkey delay from 0 to 20. Now, when the machine starts, I can press F9 more easily. What was very annoying was indeed that if there was so little time to press the key it was really easy to fail and Windows would start, but now with 20 seconds it is more than enough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.