8

I'm using alt-tab to switch applications on Ubuntu 16.04 and fully updated. There seems to be a screenshot in the way of the usual icon of the apps I'm tabbing through. Then, the application being switched to is the screenshot one not the icon.

How doenter image description here I turn off the screenshot overlay, and can you please explain what is causing this?

2
  • 1
    I experienced the same issue after a recent (March 2018) update and found it could be solved by following this answer: askubuntu.com/a/824188/40001 Mar 10 '18 at 12:59
  • The question that James shared is older than this one. This one should be marked as a duplicate.
    – Ose
    Jul 10 '19 at 10:50
13

It's due to Unity and Compiz's application switchers both being enabled with the same keybinding (alt+tab).

You can disable the Compiz Application Switcher by:

  1. sudo apt install compizconfig-settings-manager

  2. Open the CompizConfig Settings Manager by launching "ccsm"

  3. Select "Window Management"

  4. Uncheck "Application Switcher"

Now, only Unity's application switcher (Desktop > Ubuntu Unity Plugin) should appear when you press alt+tab.

3
  • Thank you.. it was so much enoying to see multiple switcher.
    – Manisha
    Aug 8 '18 at 21:12
  • Maybe use a malware or root kit checker to check your installation such as rkhunter, chkrootkit, or tiger. If Ubuntu was working normally and this came out of the blue it could be sign of compromise. Sep 15 '18 at 6:30
  • 1
    Thank you very helpful ! For step2: Open the CompizConfig Settings Manager by launching "ccsm" Goto > Ubuntu Software > Type-in: CompizConfig Setting Manager > Download and open software.
    – Manisha
    Mar 21 '19 at 14:55

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .