1

I am trying to make Chinese input work in Ubuntu 17.10. I installed the language but the input doesn't work.

Current configuration for the input method:

  • Active configuration: ibus (normally missing)
  • Normal automatic choice: ibus (normally ibus or fcitx or uim)
  • Override rule:
  • Current override choice: (en_US)
  • Current automatic choice: ibus
  • Number of valid choices: 3 (normally 1)
  • The override rule is defined in /etc/default/im-config.
  • The configuration set by im-config is activated by re-starting X.
  • Explicit selection is not required to enable the automatic configuration if the active one is default/auto/cjkv/missing.
  • Available input methods: ibus fcitx xim

Unless you really need them all, please make sure to install only one input method tool.

  • Did you add a Chinese input method, such as SunPinyin? – Gunnar Hjalmarsson Mar 4 '18 at 23:55
0

If you want use Chinese input on ubuntu:

  1. In Language Support > Install/RemoveLanguages add Chinese
  2. Install ibus framework

    sudo apt-get install ibus ibus-clutter ibus-gtk ibus-gtk3 ibus-qt4
    
  3. Start ibus framework

    sudo im-config -s ibus
    
  4. Install ibus-pinyin

    sudo apt-get install ibus-pinyin
    
  5. Configure

    Settings > Region & Language > Input Source

    Click + and click Chinese and click Chinese(pinyin)

  6. Restart, Done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.