1

Every time I start my computer I have issue with WiFi, there is an icon, indicating that I'm connected to wifi spot, but real connection is absent, so I have to restart PC and only after this WiFi is working.

Here is the output of wireless info script:

https://paste.ubuntu.com/p/ngdrnq2j8z/

Please, help

UPD: For some magic reason it started to work properly without me doing anything. I don't know if I should test your suggestions and if I can test it, since everything is fine so far. Anyway, thank you guys for your help, if issue will come back I will work on it.

1

Your Wifi card is a Qualcomm Atheros Device [168c:0042] (rev 31). There are many bug reports you can review to find similar problem and recommended solution(s):

In addition to the bug reports, there are problems and solutions posted on various forums:

I have a similar card revealed using lspci -nnv:

3c:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
    Subsystem: Bigfoot Networks, Inc. QCA6174 802.11ac Wireless Network Adapter [1a56:1535]
    Flags: bus master, fast devsel, latency 0, IRQ 136
    Memory at dd200000 (64-bit, non-prefetchable) [size=2M]
    Capabilities: <access denied>
    Kernel driver in use: ath10k_pci
    Kernel modules: ath10k_pci

The same driver ath10k_pci is used as your card. So "one driver fixes all" approach is used for bugs with your card and mine. The one bug I've been following has been fixed but it took two years to reach upstream:

To narrow down which bug effected me most accurately I used dmesg | grep ath10k:

[    3.973278] ath10k_pci 0000:3c:00.0: enabling device (0000 -> 0002)
[    3.974377] ath10k_pci 0000:3c:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    4.253816] ath10k_pci 0000:3c:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:3c:00.0.bin failed with error -2
[    4.253822] ath10k_pci 0000:3c:00.0: Direct firmware load for ath10k/cal-pci-0000:3c:00.0.bin failed with error -2
[    4.254750] ath10k_pci 0000:3c:00.0: qca6174 hw3.2 target 0x05030000 chip_id 0x00340aff sub 1a56:1535
[    4.254752] ath10k_pci 0000:3c:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[    4.255179] ath10k_pci 0000:3c:00.0: firmware ver WLAN.RM.4.4-00022-QCARMSWPZ-2 api 6 features wowlan,ignore-otp crc32 4d458559
[    4.318661] ath10k_pci 0000:3c:00.0: board_file api 2 bmi_id N/A crc32 6fc88fe7
[    4.885699] ath10k_pci 0000:3c:00.0: Unknown eventid: 90118
[    4.886304] ath10k_pci 0000:3c:00.0: htt-ver 3.32 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[    4.987424] ath10k_pci 0000:3c:00.0 wlp60s0: renamed from wlan0
[    5.820647] ath10k_pci 0000:3c:00.0: Unknown eventid: 90118

Believe it or not this is today's dmesg after the bug is fixed. The log with the bug can be viewed at the bug report just linked.

I wish there was a one-line answer I could have posted for you but at this point I can only point you in the right direction for doing your homework.

1

For this issue I would

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

To disable power management, and we can update the firmware from upstream as it has been updated recently

cd /lib/firmware/ath10k/QCA9377/hw1.0
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA9377/hw1.0/board-2.bin
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA9377/hw1.0/board.bin
sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA9377/hw1.0/firmware-5.bin

I also recommend going into the wifi router settings and change encryption to WPA2 only using AES/PSK/CCMP with no WEP or TKIP

Reboot

protected by Thomas Ward Oct 7 at 13:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.