1

I'm a bit of a novice so bear with me please! Any answers please don’t assume I know too much – I’m very much self taught and new to boot loaders etc.

I had a Windows 10 installation on my desktop (Dell Inspiron 3650, Intel i7). I've wanted to move to Linux for a while and have successfully used Ubuntu on my laptop as a dual boot. There are some things that I (sadly) absolutely need windows for (eg remote access to a server that only accepts VMware that won't run on Linux; our work email MS exchange server will only allow either MS Outlook or Mac to access). I hate the idea of running a virtual OS so I want a dual boot.

I've backed up so no problems if it all goes wrong (which it has). I really didn't mind screwing up the system so long as I can retrieve it because I'd like to understand a bit more about this sort of thing anyway. Basically I was left with a machine that wouldn't boot up at all.

I’ve now created 2 large-ish partitions on the hard drive (500GB & 1.5TB). I reinstalled windows (on the 1.5T partition) and it booted up fine. I installed Ubuntu on the 500GB partition and after turning the computer on it went straight in to Ubuntu without giving me the boot option that my laptop does (ie grub boot loader offering Ubuntu as default and Windows as alternative).

Windows is operational as is Ubuntu - I can start Ubuntu or Windows, but can only change which one loads by going in to the computer setup menu (f2) and change the settings. That option will then load every time. So I have 2 operating systems but no boot menu that lets me select which one to use.

I think the issue is that Windows 10 is using UEFI but Ubuntu needs the legacy Bios but someone out there may know differently.

So for settings, if I enter setup (f2) and go to the boot options tab and use the following settings: Boot list option – Legacy Secure boot – disabled Load legacy ROM – enabled Boot priority – (I’ve set USB 1 then ‘hard drive’ is the only internal disk option which I’ve set as 2).

  • This then loads Ubuntu without giving me the option of Windows. The 'hard drive' is presumably the 500GB partition with Ubuntu on it, ie the system isn't recognising the Windows 1.5TB partition.

If I use these settings: Boot list option – UEFI Secure boot disabled Load legacy ROM enabled Boot priority – the only options are Windows boot manager or 2 onboard NIC (which I’ve disabled).

  • this then loads Windows, with no option to run Ubuntu.

I can’t see how to get both options up there.

Ideally I’d probably opt for default windows but able to select Ubuntu, but I'd be fine with Ubuntu as default and Windows as the option I can select.

Is there something basic I can change? I can obviously get into a command line on Windows or a terminal session on Ubuntu. Interestingly, from Ubuntu’s GUI, Files won’t let me access the windows partition (says something about Windows being in hibernation, which is odd as it was shut down completely between boots **see bottom of message for details of error message). I can mount it read only from a terminal session and then access all the files and as I say I know the relevant files are all there because I can boot windows if I change the settings in the initial setup option.

If necessary I can reinstall Ubuntu / Windows / both / reformat the entire drive and repartition it; I have Windows / Ubuntu on USB sticks so easy enough to do … but I’d like to avoid spending too many hours on it if possible, and in any case that's pretty much what I've done already to get to this stage.

I’m conscious that what I’ve written is probably not enough detail on some things to give a full picture to the expert user but don’t want to make this an unreadable length – please let me know what additional information will be useful.

Many thanks!

Will

**error message when trying to access 1.5TB partition is Error mounting /dev/sda4 at /media/will/048A15BE8A15ACE4: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" "/dev/sda4" "/media/will/048A15BE8A15ACE4"' exited with non-zero exit status 14: Windows is hibernated, refused to mount. Failed to mount '/dev/sda4': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option.

0

You have a couple of issues here, so this might be considered too broad and get closed as such. Be that as it may, for your dual boot to provide teh expected menu of choices both OS's need to be installed the same way (both UEFI or both Legacy) as you have one installed via EFI and one installed via Legacy you are having to go into the BIOS and fiddle the settings to choose between them.

If you have Windows installed via EFI you'll want to follow that with Ubuntu as installing Windows after Ubuntu will trash the boot record and leave you without the option to choose Ubuntu.

For resolving the error you have posted you'll want to disable fast startup in windows.

  • The issues were as you described (no surprise there - you guys are always expert and helpful!). Initially sorted the hibernation issue by disabling fast start up. I didn't realise that the Ubuntu ISO I created in Rufus was dual Bios and UEFI; I re-created the USB ISO in UEFI only & installed over the old Ubuntu copy and it worked. Interestingly, the windows partition then wasn't working from Ubuntu (no disaster but odd) - even though fast start up disabled. I've disabled hibernation from command line in Windows and working again. Really appreciate the help, learning lots in the process! Will – Will Mar 4 '18 at 11:00
  • 1
    Note that Windows updates may turn fast start up back on. Grub only boots working Windows or Windows that is not hibernated nor needs chkdsk. In those cases directly boot Windows from UEFI and change settings or repair. – oldfred Mar 4 '18 at 14:59
  • Glad to help Will, As you are a new member, I should tell you that you should accept (or upvote once you have the reputation)the answers that help you, so that others with the same issue can find accurate answers. – Elder Geek Mar 4 '18 at 23:49
  • Thanks - done! Tried to upvote but wasn't yet allowed so have accepted the answer. Many thanks again. – Will Mar 5 '18 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.